"This file is not a valid Scrivener file."

So, I use both Scriveners for Windows and for PC, and I use Dropbox and SkyDrive to bridge the gap between computers. I just got a new Lenovo Yoga today, and as I was installing Dropbox and SkyDrive something went haywire. Whenever I try to open a .scrivx file on my Windows machines – a process that used to work perfectly – I get an error: “This file is not a valid Scrivener file.” I can open them without a problem on my MacBook Air still, but not in Windows.

Any idea why this happened? I’m happy I didn’t lose everything, but the prospect of recreating all these Scrivener files is a bit daunting.

There was an eerie bug in an earlier version of Windows (only distribution for a few weeks) that could result in a report that the project was invalid, even when it wasn’t. So the first thing I’d check is to make sure you are running 1.2.5. If not, update and let me know if the problem persists.

I was running 1.2, I think, and updating it seemed to fix the problem. That’s bizarre, though; these files worked fine last night, but after I installed Dropbox on the Lenovo, something went amiss.

In any case, thanks a bunch! You saved me oodles of time and a lot of heartache. :slight_smile:

Glad that’s all it was! It was a silly bug, if the software was closed when you tried to open the .scrivx file it would fail. If the software was already open when you double-clicked, or if you tried to open it via the recent projects menu, then it would have worked. Hence the inconsistency.