Title and author formatting

Hi there,

The referencing style I use for my writing is the Australian Guide to Legal Citation (‘AGLC’). The AGLC requires the document title to be capitalised, centred and in bold type, with the name of the author appearing in large and small caps and centred at the beginning of the article.

I have tried several different ways to achieve this in Scrivener. Most recently I tried centring:

**<$PROJECTTITLE>** <$fullname>
in a new document and adding it to the documents compiled as ‘front matter’. However, I kept getting the name of the new document appearing as the first subheading.

Has anyone else who uses document subheadings encountering a similar issue where they need to put the article/chapters title and author’s name before the first pre-formatted subheading?

I hope this makes sense.

Thank you, in advance for any thoughts/advice/comments you have.



The “Compile As-Is” checkbox in the Inspector is what you are looking for. This waives the Formatting pane rules for that one document. That means not only the formatting you use within it will be retained, but no titles will be added to the section even if they otherwise would have had one. So it’s useful for anything “odd” like dedication, copyright and title pages.

Thank you so much AmberV! I can’t believe it was so simple.

Just one thing I’m still having trouble with is I want to add a footnote at the end of my name (to thank reviewers etc.) but the footnote isn’t included in the compiled document.

Is there a tricky way around this?

Thank you for your help.



You’re welcome!

Check in the “Footnotes & Comments” compile option pane and make sure that footnotes are not being removed at this stage of the export process.

Secondly, make sure you are opening the RTF file (or whatever format it is) in a program that can actually display footnotes. :slight_smile: Notably, TextEdit will just discard them, and that is the default word processor file viewer on the Mac (also Apple Pages will ignore footnotes unless you compile to .doc/x—though of course in the latest version of Pages, it can’t even read RTF to begin with). Scrivener is capable of parsing footnotes, so dropping the compiled RTF file back into the Binder is a good test to see if the footnote is actually there.

Thanks AmberV. The plot thickens as footnotes appear ok for the other sections in the compiled document. I did double check though to make sure that footnotes weren’t being excluded in the compile options, and I am opening the RTF file in Word for Mac, which does support footnotes.

I think it may have something to do with specifying this document as ‘compile as-is’. On pg 383 of the Scrivener manual it states:

Maybe a footnote falls outside of this output? If so, do you have any other ideas on how I can get title and author (with footnote) appearing without a Scrivener section heading?

Thanks for your continued assistance.



As-Is will not prohibit footnotes from exporting. When it refers to only the text being compiled, that just means that the end result will basically be like clicking the “Text” checkbox alone in the Formatting pane, and leaving override formatting off—for that one item. Even if that class of item would ordinarily not export its text, it will if it is set to As-Is. Footnotes are considered part of the text (even though they can be off to the side in the UI, if you use non-inline).

There must be some other ingredient in the mix that is eluding me. I did test this to make sure a footnote wouldn’t get lost when placed over a placeholder, but it worked fine for me. I created an “As-Is” title page composed entirely of formatted placeholders, put down a footnote on the <$fullname> placeholder and it worked. I also tried placing the footnote highlight on just part of the placeholder, since if you do not fully select it Scrivener will only automatically highlight the middle text part excluding punctuation marks, but the result in that case was a footnote exporting correctly—while the placeholder itself breaks. So I get the text <$fullname[1]>. I don’t think that is what you are describing, but if it is then there is the solution—just make sure the whole placeholder is within the footnote highlight.

Out of curiosity, what happens if you use the Format/Convert/Inspector Footnotes to Inline Footnotes menu command on that title page? You should get grey bubble text with the footnote text inside of it, all after the > character of the placeholder. Does that work?

I have no idea why, but when I converted the footnote from ‘inspector’ to ‘inline’ (and the grey bubble appeared as you described) and I then compiled the document it worked!

I also just converted from ‘inline’ back to ‘inspector’ and compiled, and that worked too. Not sure why it wasn’t doing it earlier, but I’m pleased its working now.

Thank you so much AmberV!!