"To" replaced by or corrected to "too"

I have an odd problem with the word “to,” it gets replaced by “too” by the automatic correction as I type, so I have to constantly go back and correct it. Is there a way to tell Scrivener not to do this? I’ve experimented a little, and it doesn’t seem to do it all the time. It seems like it’s interpreting the grammar badly or something.

Example “She said to Robert.” becomes “She said too Robert.” But “What would happen to them?” is left alone.

Nothing like that happens at my Mac. Check your autocorrect settings.


[attachment=0]system preferences.png[/attachment]

Changing the preferences did nothing, but changing the list of substitutions in the System Text Preferences Keyboard tab eliminated the problem. Whatever the problem was, it was nothing to do with the actual keyboard preferences, I just had one, changing Imen to Imen-R’a. Adding a preference and deleting it again fixed the problem. Some kind of demonic system interaction, I guess.

Thanks for the suggestion!

“Imen” to “Imen-R’a”? It wasn’t “to” and “too”?

Nope. Just the single Imen substitution. After the problem went away I added to–>too just to see what would happen, and it worked just like it was supposed to, changing all the “to” instances to “too” with no problem, and I took it out and that substitution stopped. I checked MS Word, and it doesn’t use the Apple keyboard substitutions, and Textedit has the substitutions turned off by default, so I think I just never saw this behavior in other software. Not a Scrivener problem, in other words, but a Mac problem.

Your experience with to/too and mine are the same. I have similar problems with their/there - the corrections are wrong more than they are right.

In the previous paragraph Safari or what ever drives the corrections in this forum post has underlined the word “Your” in the first sentence wanting me to change it to “you’re.”

Frustrating it is.