ToC Compressed and Listing Wrong Page Numbers in Word .docx

I’m trying to get my ToC functioning properly for my print book, but having several problems. I’m compiling to .docx format. When opened in Word, the ToC is only 1/3 the width of the page. The page numbers are all off by several pages, as well. I’ve tried everything I can think of to sort this out, but having no success. See the image below. Any help would be appreciates as my deadline is nearing.

If your headings are using the standard “Heading 1”, “Heading 2” stylesheet nomenclature, you might give Word’s built-in ToC feature a try. With a document that has the stylesheets all set up right, doing so is usually a one-click type affair, and the result is going to be more flexible and reactive to changes made within the .docx.

Otherwise, for the width problem I’d look at the tab stop settings in the original binder item, and if those are good, then check the Layout being used by the ToC, and make sure its tab stops are sensible in the Section Layouts compile format pane.

As to the page numbering problem, I don’t know—but my guess would be that it has something to do with the first two sections and whatever conditions are causing them to lack the necessary bookmark to reference their page number. I’d compare how they are set up to a section like “Dedication”, which is surely similar for being a single page of content.

I’m only using the section and chapter headings pulled from the binder docs. I have not changed any heading information relating to them. My ToC does not contain any headings from within the documents. So I’m not quite sure I understand the first part of your reply.

I did try Word’s ToC feature, but it’s only picking up my chapter subheads, not the chapter titles. I don’t even want those listed as it’s too granular for my ToC. So, I’m guessing that there is no heading assigned to the documents in the binder.

I also removed all the tab settings from the section layout used for the ToC and it didn’t make any difference.

With regard to the first two pages, I set those so the page number wouldn’t show (not quite sure at the moment how I did that) as I don’t want numbering to appear on those pages, only in the ToC in reference to them.

The stylesheet assignments could be made in compile settings, they do not have to be in the editor. You would go into the Layout that produces the chapter break heading and make the style application there to the correct portion of the heading. So for example if you just want “Chapter 21” printed and not the subtitle part that prints the name of the chapter, you would make sure Heading 1 is assigned to the first line and leave the second line using a style other than “Heading #”.

So long as the layout isn’t overriding formatting then it should let the tab stops in use in the ToC file itself pass through. Granted, if the tab stops in there are in odd places on the ruler itself (Page View helps here), you might still get weird results.

Thanks for your help. I was able to get the formatting corrected on the ToC so that it’s no longer scrunched.

I do have one other major issue I’m stumped by that has not received any response. Could you possible check out the post viewtopic.php?f=2&t=50383 and give me some feedback? I posted it on the 16th and haven’t had a response from anyone yet. I can’t get the endnote formatting to produce the desired results. Thanks!