ToC no page numbers for folders

Hi,

I’m currently trying to add a ToC and compile my project. However, when all is compiled my ToC doesn’t show page numbers for my folders.

I’l get something like this:

Capter 1 Page 1
Chapter 2 ?
Chapter 2.1 Page 6
Chapter 2.2 Page 7
Chapter 2.3 Page 8
Chapter 3?
Chapter 3.1 Page 9
Chapter 3.2 Page 10

What am I doing wrong? I know I still have problems understanding how to use the section layouts properly (I haven’t assigned any yet). Could that be the cause of the question marks?
Bildschirmfoto 2018-12-17 um 15.22.00.png

In the user manual, under §22.1.2, Things to Watch Out For, it sounds like you’re dealing with “Missing page numbers”:

An example of how this might occur is if you intend to use folder names as chapter headings, but then never assign the Section Type that folders use to a Layout that prints anything (by default all Types print “as-is”, which for a folder would likely be nothing).

From your description, it sounds like that might be the very problem. “As-Is” means don’t even add a title, and while one of your folders has text content, it looks like the others only have synopses—so nothing to print.

First:

  1. Load Project ▸ Project Settings… and click on the Section Types pane if necessary.
  2. You might want to create a Type for these if there isn’t already something suitable. An example to use could be “Chapter”.
  3. In the second tab, set folders to automatically use “Chapter” (or whatever you call it).

That’s all there is to Types, really. You make up a name for how a thing should be treated, then either set it up to automatically be used based on icon type and indent level—or you can even just manually assign them by hand in the inspector.

Second:

  1. Load File ▸ Compile… and click the Assign Section Layouts… button at the bottom of the preview column.
  2. Select your “Chapter” type (might need to reveal unused types if you haven’t actually set up your binder to use it yet) in the left sidebar.
  3. Scroll through the available alternatives for chapter headings. It sounds like you might prefer one that simply prints something like “Chapter 12”, instead of including the name of the folder as well. Once you find one you like, click it to select it and then OK to save your settings.

Now in the preview column you should have a chapter break example, and if you click on the preview tile there, your folders should light up in the Contents list. The ToC should now be working much better.

Thank you very much AmberV! I’ve now started defining my section layouts and compile is starting to look good. But there are still some questions:

1.) The ToC has its own section layout, but I can’t format it in such a way that the numbers stay on the right side of the page. How do I define that?

2.) I have found Format - Paragraph - Keep with Next. But it won’t tie my headings to my paragraph. Now that I’ve defined layouts to consist of Section Title plus text, I thought it would keep my title stuck to the text but it doesn’t, resulting in single titles at the bottom of the page if I don’t add a page break.
I’d also like to tie image captions to images, is there a way to do that? (is it ok to ask in this thread?) :slight_smile:

It sounds like you are describing everything being in order, but if you have it set up right this shouldn’t be a problem. So I’d investigate what part of the equation doesn’t look right:

  • You need a special Section Type for your ToC because it requires special treatment to handle the layout.
  • So long as you pasted in a ToC using the Edit ▸ Copy Special ▸ Copy Documents as ToC menu command, then you shouldn’t have to do any further adjustment.
  • The Type needs to be assigned to your contents binder item. Easiest way to do that is to right-click on it in the binder and set its section type from the contextual menu.
  • The type needs to be assigned to the special “Table of Contents” Section Layout, in the compile overview screen. The “Table of Contents” Layout has the tab stop set flush with the right margin of the page.

Not a bad idea—but you shouldn’t have to adjust that yourself. The Layouts that make use of headings in the Paperback compile formats all have Keep With Next already applied to them (and two both lines, for those that have a subtitle). Did you maybe accidentally turn them off, since they were on by default?

Unfortunately captions aren’t a thing Scrivener does natively. You’d have to use one of the more advanced workflows (MultiMarkdown or Pandoc) in order to get proper captions straight out of the compiler.

For captions and getting into proofing what page specific text falls on, inserting your own breaks, optimising page flow, etc.—in most cases a document should be transitioned to a desktop publishing environment at some point, if the idea here is to design your own book by hand. Scrivener’s output is really more for getting you to that point with as little extra work as possible—it’s not going to replace a DTP program.

AmberV I’m so grateful for your help!!

AmberV wrote:
[*] The type needs to be assigned to the special “Table of Contents” Section Layout, in the compile overview screen. The “Table of Contents” Layout has the tab stop set flush with the right margin of the page.

I had done all the above but at some point fiddled with the settings here. I removed the check at “override text and notes formatting” and it now looks right in .odt (not in PDF, but I have to do the RTF/ODF Scan in LibreOffice anyway). So I’m really getting there now.

Could you please tell me if this has changed since 2018?
I cannot find any section layout named “table of contents”.
By default, the “contents page” sections are assigned to As-Is.

In the editor, all the titles appear on the left, with the right indents, which I determined.

When I compile, it automatically adds the chapters/subchapters… thanks to the title prefix <$hn> in the “decimal outline item.”

So far, so good.

What I do not understand is why all my titles are pushed to the right end of the page, which is not really what I would call “as-is,” since, in the editor, they are exactly as they should be.

What can I do to avoid this?
I don’t have to use as-is for the contents page, I could create another layout, but which one?
Of course, if there is indeed one named “table of contents” and all I have to do is choose it, I will be very happy :slight_smile:

A post was merged into an existing topic: Compiling the Table of Contents