Toolbar customisation doesn't fit on screen (MacBook, 12")

Scrivener 3.1.2
macOS 10.14.3
MacBook 12" (2015)

To reproduce:

  1. Scrivener running full-screen (built in display)
  2. Right-click to customise toolbar.


The modal doesn’t fit, with the action button off the bottom of the screen. Escape (or enter) removes the modal, but that’s not intuitive. If you restore Scrivener back to a regular window and try again, the modal properly sizes.


Modal should correctly resize when Scrivener is running full-screen.

Very strange! I’m afraid I have no control over that customisation panel, though, as standard Apple code handles that. Essentially, an app provides macOS with a list of what toolbar buttons are available (their icons and actions) and macOS puts them into that special customisation panel (which is why that panel is the same in all apps). I have therefore reported the bug to Apple (Apple bug ID #49108443). I bet they respond to say that they don’t intend to fix it, though, and that I shouldn’t be offering users so many toolbar button options!

Thanks and all the best,

Try increasing your screen resolution temporarily to max. I’m using a Macbook Air 11 with HiDPI enabled, which gives me Retina-style resolutions—and this problem shows up in the Retina-style (i.e. 4 pixels per dot) only. If the screen resolution is a straight 1-1 (the case for the Macbook 12 max resolution) the Done button shows up. Please let me know if this workaround works for you.

(In case you’re unfamiliar, you can change the resolution in System Preferences > Displays.)

Hope this helps!

Thanks. Given this is an edge-case use (how ofted does someone adjust their tools, while full screen, on a 12" Mac!), I’m fine with just restoring the window rather than adjusting the screen resolution. Chalking it down to another of those “weird Mac UI glitches” which we all love :slight_smile:

Thanks, Keith. Not a big bug I guess, and an Apple one at as you say. Thanks for the explination of how that panel works. Yet another bizarre macOS UI glitch. Gotta love 'em :slight_smile: