Total Progress Bar does NOT show overrun (Outliner)

Dear Scrivener,

PROBLEM: The Total Progress Bars do NOT show overruns in the Outliner.

  1. I have checked the Show Overrun box in all the text files (Blue Arrow).
  2. The Total Progress Bar in the main editor footer shows the overrun, for files and folders. (Blue Arrows)
  3. The corresponding Total Progress Bar in the outliner does not show the overrun. (Green Arrow)

How can I get the Total Progress Bar (of chapter folders) to show overruns in the Outliner?

Thank you.

The progress bar in the outliner isn’t intended to show as much detail as the individual progress bars for each document, so this isn’t really a bug in the sense of things not working the way they were programmed to.

I’ll check and see if it is a possibility to change this, but quite often there is a matter of efficiency to keep in mind with stuff like this. It may be very quick to draw all progress bars the same way, when there are potentially thousands of them in a list, but very slow to poll each document’s settings and draw individually set up progress bars in the same quantities.

Dear Amber V,

Thank you so much for your reply and for explaining the thinking behind the programming decisions.

If it would be possible to incorporate this detail without slowing down the display, I think it would be a welcome improvement that would make the Outliner clearer and more useful.

Many thanks once more.

I was going to post a similar bug for Windows not displaying the overrun colour when I saw this reply in the similar topics suggested. I’d be interested in any further thoughts on this. It seems odd to have the option of displaying ‘Total Progress’ towards a target that then displays something that is completely inaccurate. As an overwriter, the overflow is something I need to monitor carefully and am disappointed to have to rely on an external spreadsheet to be able to see the bigger picture. The ability to easily export word counts in spreadsheet format would be very useful!

At the very least might I suggest a note in the overflow colour setting and the manual to indicate that it won’t show in the Outliner.

I’d like to add my desire for this feature to be added (overflow being shown in the Outliner progress bars).