Trouble creating new project

I’ve found on multiple occasions that I have trouble creating a new Scriv project if I change the location. If I change the “Where” to an existing folder, hitting the button to create the project doesn’t do anything. If I use the dropdown and just set it to Desktop, it creates a project without any issues.

Any tips y’all could offer about this would be great. Thanks!


I have a few clarification questions for you, as I cannot replicate this yet myself.

Does this occur every time or only with certain folders? Where exactly are you trying to create the new project?

Do you have multiple drives on your computer? Are you trying to create a project on a different drive?

Which type of project are you trying to create? Does this occur with all different templates or only with a specific kind?

Thanks for your help with this.

I’ll have to test some of these parameters.

  • I think it’s occurred consistently every time I’ve tried to create a new project. Usually, I’m trying to create them in my Writing folder, but they are nested in a subfolder within that one, so the folders are different each time.
  • I don’t have different drives, but I am trying to create these folders within Dropbox. Is that the problem?
  • I have only tried this with the short story template thus far, but with your question, I attempted it with a novel template just now. Same problem: Hitting the create button after choosing the folder results in nothing happening. When I change it to Desktop, it creates the project there, and then I manually move it to where I want it to go.

Subfolders shouldn’t matter. I do suggest short folder names, because Scrivener can run afoul of the 260-character limit fairly easily.

Strong suggestion: Turn off Dropbox sync before you open Scrivener. Seriously. Turn it back on immediately afterwards. Scrivener and Dropbox do not work well together.

Finally, try changing the permissions on your Writing folder. Make sure the folder is not set to read-only, and make sure you as a user have permissions to write there. You might try running Scrivener as Administrator (last resort) to see if it will write when you do (if so, indicates a permissions problem). I don’t really recommend the last as a regular practice; you can bollix your system royally well by running stuff as admin when you needn’t.

How to check permissions: in File Explorer, right click on the folder and choose properties.
The first window that pops up, at the bottom, shows “read only”. If that’s CHECKED, UNCHECK it. If it’s black, you may want to uncheck it (that means some things in the folder are read-only and some are not).
Click the Security tab, and see what permissions you’re given for the folder.

You should have all permissions allowed to you as either Authenticated Users or Users, except full control or special permissions.

I hope at least one of those things helps.

What kind of issues does Scrivener have with Dropbox? Any details?

Otherwise, all the other parameters you’ve listed are already true, but I appreciate the help.

I too would like to know. I’ve been using Windows Scrivener since before 1.0 was released and the only times I’ve had issues with DropBox were the times I had the same project open on two computers at once.