Trouble installing Scrivener


I’m using a Dell Latitude 3400 with Ubuntu 18.04.3 LTS 64 bit, GNOME: 3.28.2

I’ve installed Scrivener on this system before and used it without a problem. I had to reboot the system this morning and ever since then I’m having trouble installing Scrivener.

This is what I did. I downloaded Scrivener from … -amd64.deb
Then I downloaded libpng12 package from … 0/download
Then I ran these commands on the terminal:
$ wget … _amd64.deb

$ wget … _amd64.deb

$ sudo dpkg -i libgstreamer*.deb

This is where I run into problems. Attaching the screenshot.

How can I sort this out? I’m not computer literate so am out of my depth in discussions about WINE, etc.

I’m totally incapacitated without Scrivener so any help in fixing this would be a godsend. Thanks a lot in advance.

Seems like you lack one file. Try to run sudo apt install libgstreamer1.0-0 prior to running your commands.
This is not the version it’s askin for, but it might work still.

But the more interesting solution I would suggest is installing an Appimage version of Scrivener. This will be very straightforward to run. Just follow the instructions here :

Thank you so much for the suggestion to run AppImage. Took me a while to understand what it was and how to use it. But boy! does it make life so much easier! Phew!

I managed to get Scrivener working on Linux Mint 18 or 19 computer (can’t remember which now) without AppImage, but there were still some bugs that needed ironed out. The AppImage is just download and go. Recently installed it on this Linux Mint 20 laptop (Dell XPS M1330) with zero issues. I don’t know if it works that easily on non-Ubuntu based distributions but I’m guessing (since an AppImage is self-contained) that it should work anywhere.