Trouble with "open clicked Scrivener Links in current editor"

In one of my projects (not all), no matter what I choose for “open clicked Scrivener Links in”, it will only open in the “other editor.” I copied the project to a newly named second version, and the problem persists. Any ideas on how to get my documents to open in the “current editor”? Many thanks.

Hello Br,
That is the default behaviour. If you want it to open just in the current editor, right mouse on it and select open in current editor on the menu. That option is not a toggle, it has to be selected each time.

Thanks. My problem is that I can’t change the default. I’d like the default to be “current editor.” I’m thinking it must be some kind of bug, because in my other projects I can set the default to “current editor.” But I can’t get scrivener to recognize it in this project. I tried the right click solution you offered, thank you, but it’s only offering me “other editor” – it wrongly thinks it’s set to “current.” (That works in other projects, where I’m not having this problem.)

I tried restoring defaults in options, but that didn’t help either.

I’m stumped!

The only way I know of changing the default is in options / navigation and in the right of the panel select the Open scrivener links in toggle. If that doesn’t work you are bugged.

To confirm, the only setting in the software that changes how this works is in File ▸ Options…, under Behaviors: Document Links. Set Open clicked Scrivener Links in: Current Editor.

There is no per-project setting for this and never has been. That setting has always worked for me by the way, I prefer to keep work in the same split for most things.

P.S. Sorry, just noticed this was in the tech support area rather than the beta board. The above all applies, but Settings are in the Tools menu instead of File, and the setting itself is in the Navigation tab, at the bottom.

Thank you for the replies! I think I’m going to open a new project and copy over my text, and hope whatever bug this is stays away.

In case it helps anyone else – I created a new project, made sure the setting on this was working correctly, and then drag-and-dropped my folders into the new project. So far, this has gotten rid of the issue. I guess it was a bug in that one project!