Two "Novel" templates and other templates missing?

Not sure what’s going on here, but I have two “Novel” templates in the latest 1.8 release. One of them seems to be deletable (options->Delete selected template), but it won’t delete, giving me error “Could not remove template: Novel”.

Also, it’s not showing two custom templates in %LOCALAPPDATA%\Scrivener\Scrivener\ProjectTemplates. These templates are rather old, from several releases ago, so maybe that’s why they don’t show up?

Something is going on, I think. I did a clean install of version 1.8.0 (and removed the %LOCALAPPDATA%\Scrivener\ folder) and new the templates are not working as before.

For instance, the typical instruction document above the manuscript comes up empty when creating a new project. :confused:

Sorry, Robert, I thought I had replied to this earlier. There does seem to be an issue with 1.8 not recognising some earlier custom templates, but I haven’t sorted out what specifically is the trigger, whether it’s the template having been saved in a certain version or first created in a specific version, etc. Do you know which versions were used for your templates, out of curiosity, or would you be willing to attach them here or send them to AT literatureandlatte DOT com? It may not matter, if the developers can sort this out from the other side, but additional samples to test with would help. I’m aware the NaNoWriMo 2014 template does not load correctly in 1.8, but I haven’t had the same issue with most of the other templates I’ve been testing.

I did find with the NaNo template that editing the base project in 1.8 and then re-saving as a template did correctly create a new template that appeared in the New Project window for 1.8, so if you have projects built off your missing templates, you should be able to do the same thing, possibly copying the project first if you’re going to need to clean it up to bring it back to template state. Ideally we’ll get this bug sorted for the next release so the older templates will load again, but resaving them will be a faster solution if you need them now.

r6d2, I’m not seeing the problem you’re describing in any of the default project templates; that sounds more like either an installation issue or a project-creation problem solved by deleting the new project and trying again or at most a reinstall. The ProjectTemplates folder saved in the local AppData isn’t related to the built-in templates, so deleting that folder wouldn’t have any affect on the default templates. Were you talking about a custom one?

I can’t recall having created or downloaded these templates, so it’s likely they’re very old. One of them is a NaNoWriMo template, but I don’t recall making it or installing it, yet it has a Nov 3, 2014 timestamp.

I tried uploading the templates to this thread, but the forum software thinks the “.scrivtemplate” is a possible attack vector, and is rejecting it, even if I add a .txt extension. I just sent an email from my work with a link to this forum post.

It happened with the default templates Novel and Novel with parts. I’ve not tried any of the others. I’ll try reinstalling again.

In order to have a full clean install, which folders should I remove manually after un-installing the current instance?

Thanks, Robert, I’ve got the email with the templates.

r6d2, if you uninstall Scrivener and its directory remains, e.g. C:\Program Files (x86)\Scrivener, just delete that whole directory. It means you’ll have to re-download any dictionaries and you’d lose any crash reports, but otherwise everything in there that you need will be re-created in the reinstallation.

Thanks a lot, Jennifer! That worked!