Typewriter mode not working at all!

First of all I really love Scrivener - it does improve my work as a writer a lot. Great.

One issue though - I can’t get the typewriter mode to work. Neither in the Editor nor in Full Screen mode. I can turn it on and off, change the setting, set it on default - it simply does not work.

I’m running Scrivener on macOS 12.3.1 / Apple Sillicon.

Any help would be greatly appreciated.

Hello Kenda, and welcome to the forum.

In your note, you said you’re using MacOS 12.3.1 on a Mac with Apple Silicon. Which version of Scrivener do you have installed?

Does typewriter scrolling work if you try using it in a different Scrivener project? That is, if you create a second project and enable that setting, will it work in the new project?

Alternatively, you might try opening Scrivener’s Interactive Tutorial via the Help menu and see if you can get typewriter scrolling to work there. The Tutorial is a reasonably complex project, so it’s a good testing space to see if an issue is project-specific or affecting Scrivener on a wider basis.

If the Tutorial is also affected, you might reset Scrivener’s preferences to see if that will correct the issue.

1 Like

I’m running Scrivener 3.2.3 on Apple Silicon with 12.4. No problem here.



1 Like

Hi Ruth and thank you for your swift reply,

it is strange. Typewritermode DOES work in the Tutorial Project but not in any other projects, new or older.

Wait… so it DOES work in the documents created by you in the Tutorial Project. But as soon as I create a new document within the Tutorial Project it does not work on that one.

Oh, and I’m running the latest version of Scrivener… 3.2.3

Thank you for testing that and for your version information, Kenda. I appreciate it.

In the new documents, how much text have you added to test the typewriter scrolling?

I ask because sometimes it seems that function isn’t working on my Mac, but my document is too short to really benefit from the feature.

Once I get longer documents that have text “off screen,” I’ll realize that the scrolling has been working.

If your documents are long enough that you should have noticed the scrolling feature working and it’s not, then please reset the preferences to see if that will resolve the issue.

1 Like

Thanks a lot, Ruth.

Not enough text seems to be the problem. Once I have enough lines it seems to work properly.

Cool - off to write some stuff. Thanks again and keep up the good work.

1 Like