Typewriter Mode

The new typewriter mode in 1.7/8 is great for just churning out words and I really appreciated the effort in adding it.

However, the added behaviour it brings of jumping the text around the screen so whereever you have clicked scrolls to the center on the screen is rather annoying.

For example, if I have 2-3 pages of text that I am reading through and I click on a word somewhere near the bottom of the viewable page (say to correct a misspelling), the whole page leaps up the screen until the word I clicked on appears in the middle, causing me to hunt around until I can find it again (as it is no longer under the mouse cursor), completely interrupting the flow.

I would like to suggest two possible additions to the typewriter mode that would make it (for me at least) infinitely more useful.

  1. Have the ability to independently choose whether or not to apply typewriter mode in both fullscreen mode and ‘normal’ mode. That way I could have it on in full screen mode where I do most of my typing, and have it turned off in normal mode and not have the page jump around where I do most of my reading. That would be perfect. Maybe a little icon somewhere down in the status bar showing a typewriter or a notepad so we can tell what mode we are in, perhaps even allowing the user to toggle the mode via clicking on the icon.

  2. The second suggestion is for when typewriter mode is turned on. It would be very useful if the centre line (i.e. the line that the cursor is always on when typing) was allowed to have a different background colour (a user selectable colour) to the rest of the page, this would make is very easy to always know where to look if the page does jump around a bit.

Just my 2c worth.

Thank you for an excellent program though and for all the effort everyone involved has put into it!

If you go to Edit then to Options and then find the Editor Tab you will be able to turn the typewriter mode off and on at will.

I understand how to turn it off (and on, at will), its just that I really would like it on in full screen mode and would rather not have it on in normal mode, and going to Edit > Option > etc every time I jump between full screen and normal mode is going to get very tiring very quickly, hence the suggestions.

It is already independent. Edit > Options >Editor tab.

There are are two check boxes ‘Typewriter scrolling’ refers to typewriter scrolling in the editor. Below that is a check box for 'Fullscreen type writer scrolling. These options are independent of one another.

Ah… then I did miss something! Seems Lee is already way ahead of me.

Thank you StaceyUK.

Well I do declare Bladesong just because I missed out the description of the two boxes StaceyUk gets the credit/ :smiley: :smiley: :smiley: :mrgreen:

It would be nice to have the option to put a button for this on the toolbar. I like typewriter mode for writing, but not for any kind of editing. This would just make switching back and forth simpler and quicker.

I would love a shortcut to turn Typewriter Mode on/off. As it has been said, as it’s implemented this is a great feature for writing, but no so much for editing.

For a more stable/intuitive (less jumpy) implementation of Typewriter Mode, I would like to point you to writemonkey:

That’s what I used to write before Scrivener, btw.

Mistakes were made by both parties Grandad7, although mine was by far the greater.
You did indeed miss out on the description of the two boxes (unforgivable really :wink: ), but I made the greater mistake of not actually checking properly before (not) commenting.

So if StaceyUK does not mind I wold like to award you with half the credit (it feels wrong to deprive StaceyUK of all of it :smiley: ) and an honest thank you for taking the time to reply in the first place.

Hell I don’t care as long as you’re sorted! :smiley:

Oh I’m sorted thanks StaceyUK.

I have even figured out the typewriter mode :smiley:

Ironically for me the typewriting mode has stopped working for some unknown reason, I have tried clearing the ticks in the boxes and then restating the program and reticking them still will not work. I will post it as a bug.