typewriter scrolling on page view?

It seems that there is no way to turn this on, as the toggle is grayed out when I’m in page view. But sometimes I like to write in Page View, and I appreciate the way typewriter saves my neck. In fact, when I show Scrivener to friends, there are three main points that seem to sell it more than anything. Corkboard, Saved Search, and TYPEWRITER SCROLLING. Not necessarily in that order. So, just asking. Pretty please? :slight_smile:

Unfortunately this isn’t nearly as easy as it may seem, which is why the two features are incompatible. Typewriter scrolling works by automatically adjusting the height of your editor to artificially add space to the bottom of the document—basically as if you had done it yourself, by hitting the return key over and over until the last line of the document was in the middle. Well, it just does that part for you, and then hides the fact that this is what it is doing. This technique doesn’t work when the document must conform to a static height.

Something you could try is “Fixed Width”, instead of Page View. This is off by default (though if you’ve ever used Full Screen you’ve probably seen it there). You can enable it by going into the Editor preference pane and disabling the “Full screen only” checkbox in the middle along the right-hand side. There are some other settings here you could play with to get a look you prefer, such as adding a little margin, changing the background colour and so on.