Typewriter scrolling.

I really like this feature, but since I updated to Vs 2…0 I can’t activate typewriter scrolling in composition mode despite having turned it on in the menu bar. or using the keyboard shortcut. My text remains firmly stuck in the top left of my screen!
Anyone got any good ideas about what I am doing wrong??

In Composition mode, slide the mouse up to the top of the screen and check the Format/Options/ sub-menu to make sure there is a checkmark beside typewriter scrolling. It should be working just fine with the shortcuts, but one thing to point out is that there is no way to see the toolbar from Composition mode, so all that button will ever do is toggle typewriter scrolling for the main editors. This setting is specific to the editor, not global to the project.

The only other thing I can think of is that you haven’t typed in enough content to get half-way down the screen. Typewriter scrolling only kicks in once it needs to, at the set point you’ve chosen in the Editor preference pane, in the top-right section, “Typewriter scroll line”. While you’re at it, that’s another thing to check. It is actually possible to make it so the scrolling point is near the top of the screen, the middle is just the default.

Dear Both…thanks for the tips. I will try them out shortly. Best, Rod.

I am having the same problem. I cannot get typewriter scrolling to turn on either in the editor or composition mode. It is ticked in the Format menu and I have plenty of text on screen. I am trying to work in Scrivening mode, but it doesn’t seem to work in a single document either. I am using version 2.0 of Scrivener on a 15" Macbook Pro Retina running Yosemite.

Any help would be gratefully appreciated.


You don’t mention whether you’ve checked in the Editor preference pane where the scrolling point has been set. As Amber states, it’s possible to set the scroll point near the top of the screen. But it’s also perfectly possible to set it in the bottom quarter or third, so that the “typing-point” in your text may not have reached it yet.

It is set as middle and I am using a Mac. I’m working with 17,000 words worth of text at 125% zoom, so it is more than filling the screen.


When you toggle typewriter scrolling on/off (CTRL CMD T) does the toolbar icon change (with the green/yellow arrow) to indicate that typewriter scrolling has been turned on/off?


If not, a reinstall from the latest Scrivener build might help.

Took me a while to find it because it isn’t on the default toolbar, but once I had it there the button did change when I toggled, but it still didn’t change the editor behaviour.

A glitch in the install, perhaps.

If it clearly isn’t working at all – and if you have tried the standard troubleshooting steps of (1) closing and relaunching the program, and (2) rebooting your Mac – I would try creating a new test project (using one of the standard templates) to see if it works in that project.

If it still doesn’t work, I would uninstall Scrivener, reboot the Mac, grab a copy of the latest Scrivener build, reinstall the software, and then try again.

I have tried all those steps including uninstalling Scrivener and reinstalling from a fresh download. Typewriter mode is still not working.

Wonder if there is a plist that is stuck, or a cache file that needs to be purged.

I’d try toggling the scroll-line settings in preferences and/or restoring the preference defaults to see if either of those changes would tickle Scrivener back into full swing.

Hopefully one of the devs will have a solution for you.

[attachment=0]scrolling position.png[/attachment]

I’ve tried playing with the settings you suggested. I think I need to stop worrying about it for now, unless someone comes up with a possible solution, and get back to writing. It’s not the end of the world.

Just as inexplicably, today it seems to be working perfectly. Clearly the machine needed a good night’s sleep.

Thanks for the help.


Did you change any configuration options between then and now, even in System Preferences? Even if not, it wouldn’t terribly surprise me, especially with Retina involved, there are still a few lingering display glitches with that technology at the operating system and software foundation level.

I don’t think I made any changes. Just got on with writing and realised it was working.


I have the opposite problem. For some reason, even though I have typewriter scrolling turned off, the editor window jumps to the middle of the screen. This only happens when I highlight and then delete a chunk of text. Very strange.

And yes, typewriter scrolling is definitely turned off!

That is probably a known bug that is rather tricky to track down, and has nothing to do with typewriter scrolling. The problem seems to more mirror the behaviour of what happens when your cursor is off-screen and you start typing, it jumps to the middle a bit like typewriter scrolling (but it doesn’t stick, so that’s the end of the comparison). So it’s almost like the system is confused over where the cursor is. I get it most often when scrolling around and then typing, but I don’t think Keith has ever managed to reproduce it reliably. The funny thing is that once I find a spot that acts this way, it keeps acting that way repeatedly, but if I restart the software that spot will be fine and another has the problem. So it’s most certainly some kind of “while running” state problem, which is part of what makes it a difficult insect to locate.

I demand you fix it, that you release the iOS version of Scriv from captivity, port it to Android and develop a web-based version. Immediately. :smiley:

In the meantime I’ll restart the software. Thanks Ioa.

I’ll be right back with that!