typing problem


I just recently downloaded the most current beta and I am new to using Scrivener. I installed it on a Window 7 64 bit computer. I skimmed the boards and did a search but I have not seen anything similar to the problem that is occurring. When I type (quite often in the cork board or binder but main text field as well) even though I might press “I” it might put “e” or another letter instead. This happens randomly when typing different letters so I don’t know if there is any consistency (I have not really tried to find out). Would uninstalling and reinstalling the program fix this, or is there another method I could try? It is a pain to have to frequently try and retype the same word over.

I have tried uninstalling and reinstalling the program (including restarting the computer after I uninstalled to make sure it was uninstalled properly) it still is doing the same thing. When I am typing even though I press one letter it inserts another. I do not have this problem with any other programs, I have only seen this in Scrivener. Is there anyway of fixing this?

Ouch. I had one other user report this a few betas ago, but we still haven’t rooted out the cause. Just so I’m clear on this, you can type the same exact phrase multiple times and get completely different letter replacements each time? E.g. you type: “Hello, world!” three times and get something like “Hillo, werld! Yelwo, world! Hellp, rorld!” where sometimes the letter comes across properly and sometimes it is replaced, but it is not consistently replaced with the same character.

Absolute first thing to check would be your keyboard–try swapping to a different one if you have one available, just to make sure it’s not something triggered by that hardware. If the keyboard itself is broken, you’d probably notice this in other applications too, but it’s worth trying anyway just in case the bug is between the keyboard model and Scrivener. If that does fix it, please let me know what keyboard you were using!

Otherwise, I’m afraid I don’t have a fix for this at the moment, but if you’re willing to spend a little time on this to help us figure out why some this is happening, gathering some information about your computer settings would be great.

First, could you let me know what input language and keyboard layout you’re using when working in Scrivener (it can change per application)? If you don’t see the language bar icon in the taskbar or up at the top of the screen, you can turn it on by following the directions on the MS site here (it says Vista but it’s accurate for Win7 as well). If you only have one language and layout installed it won’t turn on, in which case just look in the Text Services and Input Languages (Control Panel>Regions and Language>Keyboards>Keyboards and Languages>Change Keyboards) and see what your default setting is. If you do have multiple languages or layouts, once you have the language bar visible, put the focus back in Scrivener’s editor and then see what language/layout it lists, e.g. “EN English (United States) / United States-International” or “FR French (France) / French”. (If you only have one language installed, it will only show the second part, which is the keyboard layout).

Along with that, what localization of Windows are you running (French, English, Chinese, etc.), and is your account standard or administrator (new Win 7 accounts are admin by default)?

Finally, there are a couple build-in Microsoft diagnostic tools you could run that will check your input and display devices. These don’t collect any personal information, just the technical specs of your hardware and drivers, so running them, saving the results, and sending that to our support email could help us figure out what in your computer’s set up Scrivener is hiccuping over. They’re both easy to run with just a few clicks, so if you’re willing to do that I’ll post the directions for how to access those and save the info from them.

Thank you for your interest in Scrivener–I’m sorry you’ve run into this bug, but I hope with a little more data we’ll be able to pinpoint the issue so Lee can get it fixed!

Hi, thanks for the reply. I’ll certainly try and help you to try and figure out how to get it fixed, I heard about Scrivener a few years back and I’ve been sad that it has only been for Mac so I’m exited about the Windows version.

Yes the characters seem to be mostly random, ex:

Mn nami it bob
Mn nami ib bob
My aami ib bob
Ma nami is oob
My aami io bob
My aami is bob
Healo iow are you
Hillo roy are you
Hrlla hoy are you
Hhlla hoy are you
Hyllo how arh you
Hhlla hoy are you

As for it being the keyboard I don’t have any problems with other programs, but I can’t check for sure if it is the keyboard because I have a laptop and do not own an a plug in keyboard. But I can give you the model info:
Toshiba L645D
AMD Turion II P520 Dual core 2.3 ghz
4 gb ram
64 big os

I will look into the language bit and repost when I have that info.

I have only have one language installed (english us), its a US Window 7 and yes I am using the administrator. I checked the language bar and there is no option for other languages. I would like to follow the steps for the diagnostic, please send me the directions.

Thank you for all the details and for taking a little extra time with this. For the diagnostics, there are two tools to run.

System Information:

  1. Click the Windows “Start” button and type “msinfo32” in the search box
  2. Click the resulting program to run it
  3. Once it’s finished, choose File>Save and then type in a name for it (it will save as a .nfo file)

DirectX Diagnostic Tool:

  1. Click the Windows “Start” button and type “dxdiag” in the search box
  2. Click the resulting program to run it
  3. After it’s run, click the “Save All Information” button and give it a name (it will save as a .txt file)

Once you’ve gotten each of these files, select them and right-click, then choose “Send to>Compressed (zip) file” and you can send that as an attachment to support AT literatureandlatte DOT com. Thank you!

I’ll do that, thank you for your help.

I am having the same problem as the one reported above. I downloaded the new beta today with no previous installations. I am on a Sony Vaio laptop running Windows 7.

Also, I only have one language/keyboard installed - English US. I am having no problems in any other program.

My name is Bob
My naie is Bob
My nami is Bob
My name is Bob

Hello how are you today?
Hollo how are you today?
Heolo how are you today?
Hello how are you tooay?

I om fine thank yoi
I am fine toan you
I am fine ohank you
I am fine toank you

Hi Mamma_D,

Thank you for the report, though I’m terribly sorry you’re also experiencing this. If you’re willing, following the steps I outlined above and sending the results will provide some system diagnostics from your computer that may help Lee find the problem.

If you copy the text typed into Scrivener and paste it into another program like Notepad, does it appear properly there or look the same as in Scrivener?

Also, if you boot in Safe Mode and try typing in Scrivener, do you still get this issue? If you have any kind of third-party tool that hijacks text input, such as some kind of text expander tool or keyboard macro settings, even if you’re not getting trouble in other programs, there might be some conflict between that service and Scrivener. Booting in SM should prevent them from automatically running when you sign in, so if it works then, we can narrow our search.

Similar to that, possibly part of another program like security software, anti-keylogging features have caused problems like this in certain programs, so that’s also something to check for if you have anything like that turned on.

Something else to try is a scan for malware or viruses. It seems unlikely that you’d only be experiencing this in one program if that is the culprit, but the symptom itself is a bit malware-like, so it’s worth a shot.

Jennifer just a short point. These are NOT random inserts (if the output we are looking at is real). It is always from within four or five letters. It looks like characters going into a buffer somewhere and then coming out of the buffer and with characters being reused.

Must start writing soon… procrastination mode off… soon

EDIT take that back the first one DOES have non used letters in it. V odd.

No, your point is valid; my example was a false one based on the description from the earlier report. Assuming the text samples from the users here reporting this are correct, then I think you’re quite right.

Restarted in safe mode and voila! it worked! Going on what you said, disabled Constant Guard by Comcast/Xfinity (password protection software) and it did the trick. Thanks for the help!

Excellent! I’m so glad you’ve nailed it, and thank you for reporting back. If there’s a whitelist for the protection software, you may be able to add Scrivener and have it running without having to disable it entirely (or perhaps that’s what you did). I’ll let Lee know, to see what he can work out on Scrivener’s end, but this is happy news.

Just wanted to update:

I do have C.G. but since the new beta is out I decided to try installing that first. The first time I downloaded and installed 26 the same typing problems was occurring. However, I went into computer and uninstall program and noticed that 25 was still installed so I removed that (not realizing it would uninstall both). I tried installing 26 again and typed a paragraph, so far I have noticed no typing problem. So hopefully it will work fine w/o any further steps. (Side note: When the typing problem occurred I did notice the letters were more sporadic typing fast where as typing slow it MIGHT type correctly)

Thanks for all the help.