Ugly fonts


Ever since the release of Scrivener, I am experiencing weird issues with font display. And no matter what I do and what kind of setting I change (either in Scrivener itself or in the OS), I’m unable to fix it. So I’m trying my luck here with hopes someone will know what to do…

Whenever I set font via Select Font window, the font in the editor looks blurry and has jagged edges as shown in the first image below. It can’t be because of the font itself since it looks completely fine in every other editing software no matter the size + when I use regular window in format bar to change the font, it also looks normal.

It’s annoying but since the window in the format bar works just fine, I wouldn’t care.


It’s impossible to set nice looking font for the interface because it looks ugly in places where there’s supposed to be bold variant of the selected font. As shown in the second picture, Scrivener chooses to render those blurry, jagged letters even though – once again – the exact same font looks nice and smooth in the editor. (For better view, zoom in the image.) It’s frustrating and distracting.

Is there anything I can do to fix it?

Not sure that can really fix your issue with the interface itself, but have you played with this setting ?


Thank you for reply! Yes, I tried to change this setting but it only affects font rendering in the editor. :frowning:

If you would have said that it does the same with other apps, I would have known where to orient you in the Windows settings… but, if I understand right, that problem is limited to Scrivener.
And you say it is only since the last update…
That is definitely a matter to be handled by LL staff.
Perhaps you should contact them directly. They are usually pretty quick.

Yes, I have this issue with Scrivener only as far as I’m aware… What is interesting, though, is the fact that sometimes the font in the interface looks correctly right after I change it in Options. But once I restart Scrivener, it’s reverted back to its ugly form.

And I’m sorry for not being clear, English is not my native language — fonts never displayed correctly in Scrivener 3 for me (on neither Win 7 nor Win 10). None of the updates fixed it, unfortunately.

This might improve your situation: (Windows settings)


But that’ll affect everything, all your apps. So, if it doesn’t fix your issue, set it back as it was.

I very much appreciate your help, thank you! But I’ve tried this many times before and it didn’t solve the issue. ClearType seems to affect every single letter in OS and every software, Scrivener included, but it does absolutely nothing to the bold variants in the interface.

The fact that you can get the font to look nice in the editor when selecting it one way, and ugly when selecting it another way, seems to me like something LL staff would really want to know about.
In my opinion, you should contact them, and include as much details as possible.
Especially this:

If you do contact them, include a link to this here thread.

You’re right, I’m going to contact them. Anyway, thank you for taking your time to try to help me. :slight_smile: Have a nice day!

1 Like