UK English spell check does not appear to work in Beta 30

I have set the spell check option to automatically highlight spelling errors. Also, the dictionary has been set to English (United Kingdom-en-gb) under Options - Corrections.
However, it fails to highlight words that may be correct in US English, but incorrect in UK English. For eg, organization, recognize, optimize.
Please note that the Mac version of Scrivener works flawlessly and flags off these errors without issues. It is the Windows version that seems to have this problem. So, are there any files I can copy from the Mac version and import them into the Windows version (Beta 30) to fix this issue?
Thanks for reading!

They use different spell check engines, so likely not.

However, it seems that your dictionary includes some US English words (seems the OED allows -ize). You can replace the dictionary files (exact spelling is required), and you can even edit them (with a decent editor. I use Notepad++ for the purpose). Thus, you could DELETE from the file the “z” words that should be “s” words.

You can even create and download your own dictionary from SCOWL, at Choose the en_GB-ise option at the top, choose the word frequency you want it to contain, UNCHECK the “ize” spelling choice. You may or may not want to allow spelling variants, Hacker language, or diacritics. Download as hunspell dictionary.

Once you’ve downloaded it, unzip the file, open the folder, and change the names to en-GB.aff and en-GB.dic. Exactly those names (hardcoded into Scrivener). Copy them into C:\Program Files\Scrivener\hunspell\dicts\English-en-GB, overwriting the ones that were in there.

You could even load two dictionaries, by using a different country’s name. You could load the -ize English dictionary into, say, the Australian or Canadian dictionary space. Scrivener doesn’t really care which dictionary you put where, as long as they’re in Hunspell format and have the EXACT names that are supposed to be there. The license file for the dictionaries (the README file) should be included, but it doesn’t need an exact name; it just needs to be present (legal reasons).

Does that help?

And if you do this and run into trouble, don’t worry; the originals are easily recovered (delete the new dictionary files and re-download Scrivener’s dictionary).

Apologies for the delay in getting back. Saw your reply only today.
Thank you! I followed your instructions and it worked great.
Btw, I did not see an option on SCOWL where I could, as you note, “choose the word frequency you want it to contain”,
Thanks yet again for your revert. It was most helpful.

Just saw this; sorry for the delay.

This should show the location of the frequency thing. Sorry, they didn’t call it frequency; they called it size. I set to 95 and include every option I want. I get about 350k words.

For those with only one dictionary installed(?), I found it in a subdirectory here: [b]C:\Program Files\Scrivener\hunspell\dict[/b] - note the removal of the “s” in “dicts”. These instructions are spot on and work. Maybe they should be part of a FAQ or How-To?
EDIT: Be sure to change the downloaded names - they come with underscores, not dashes. It makes a difference.