Unable to remove highlighting

First, this is for Scrivener Windows Version: 3.0.1.0 (1274136) 64-bit - 28 Apr 2021

I have a page with some highlighting I did to test the highlight function. I’ve closed and reopened Scrivener, gone back to the page and now I can not remove the highlighting. I have tried right click->Highlight->Remove color and right click->Text color->Remove color with no luck.

I had the word “highlighted” with "highlight’ highlighted but not the ‘ed’ part.

I tried deleting the highlighted part of the word and retyping and that worked (the highlighting disappeared) except now the word "highlighted’ is flagged as a spelling error where it wasn’t before.

Then I tried typing “highlighted” again after the original sentence and the highlighting was applied to what I was typing!

I was using the Scrivener tutorial when I had this problem.

I opened a new blank project and tried to recreate the problem but couldn’t. Highlighting and the removal of highlighting seemed to work fine.

Any ideas?

What happens if you select the text, then right click, then Style, then No Style?

I tried as you suggested but there was no change in the highlighting.

ok then what happens if you select the entire sentence, cut it with Ctrl+x, and then immediately paste it as plain text with Ctrl+Shift+v ?

It looks like you’ve run a project search for “highlight”, and that search term is being highlighted in the text editor. It should only be showing if the search collection is open in the binder, although the binder itself could be hidden–you can toggle it on in that case via View > Binder. You should then see a striped binder area showing the search collection (probably Search Results, but it could be any saved search). You can close that and return to the regular binder view by clicking the “x” in the collection header:
[attachment=0]ProjectSearchHighlight.png[/attachment]
When you’re no longer viewing the search results, the search term will also no longer be highlighted in the editor.

If the binder is open but not showing search results, then there does seem to be something buggy with the project UI. You might in that case try holding the Alt key while opening the File menu, then selecting Close Project and Clear Interface Settings. That will clear out other project-specific settings as well–editor layout, whether label colour is shown certain places, that sort of thing–but it may remove whatever gremlin is causing the search highlight to show when it shouldn’t.

Thank you Jennifer. You are absolutely right! I didn’t notice that I had a search active or that my highlight color was the same as the search highlight color.