Unable to set Templates folder in new documents

I´m running Scrivener on a MB Pro with OS X 10.13.6 german. Since I´ve updated my Scrivener 3 to the latest release I no longer can set the Templates folder. Even when I create a new document with a project template with had a template folder defined it doesn´t work any longer. Existing projects still have their template folders working. When I open the project settings and navigate to the Special Folders section, even in existing documents, the “Templates Folder” drop down is empty while the “Default new bookmarks folder” is populated and working.
If you need further informations or screenshots please don´t hesitate to ask.

Best regards,


Hello, I have tried to reproduce this (I have 10.14 and cannot test 10.13, so this may be a factor):

  1. Create a new project test, using the “Leer” starter.
  2. Click on the research folder and create a test folder within it. I then add one file to this just to there is something there.
  3. Open project settings and examine the Special Folders pane. I can see the test folder I created, using the template dropdown. So I select it and click OK.
  4. The icon changes for both the folder and its subdocument.
  5. From the Draft folder, I use the `` shortcut, which by default creates a new document using the first document template in the list.

So this all appears to be working, and I tested in German just to make sure there wasn’t a problem with the localisation files. You mentioned updating to the most recent version (3.1.5), have you tried running the older version again, to see if it still works there? And if it does, perhaps in the process of upgrading to 3.1.5 again (which I’d do from a fresh download rather than using the updater), it may have sorted itself out. You’d be surprised what kind of strange things can happen to the UI with installs.

Otherwise if refused to work after that, I’m afraid we’ll need a little more info—perhaps a simple test project created using a similar checklist as above, but where it demonstrates the folder cannot be seen.