Unable to tile Scrivener with any other program

I’m on 3.2.2 of Scrivener, macOS Big Sur 11.6, on a MacBook Air M1.

At some point in the recent past I’ve stopped being able to tile the Scrivener window with any other program. Not even Messages. My known method of doing this in the past was to open up mission control and drag the other program over the full screen window thumbnail of Scrivener. Or vice versa.

This no longer works for any combination of Scrivener with any other program. I can still tile other programs (Safari, Messages, Mail, Good Notes) with any other program - just not Scrivener. What am I missing? Have I not ever been able to do this and just forgot?

As best I can tell, this is a bug with macOS itself, and its failure to recognise Scrivener’s project window as a valid target for that feature. I’m not aware of any way to fix it. It’s something I’ve seen come and go over the years, ever since they added that feature to the OS in. Every once in a while I’ll be asked to look into a bug about it, and it refuses to work at all, so I can’t test. A year or two later I’m on a different OS version, and it works fine. Then a year later it doesn’t. :woman_shrugging:

But that’s about the extent of effort I’ve put into it. If the feature actually matters to you, then you might want to hunt down Apple troubleshooting on it and see if it is possible to resolve.


  • Try using the Window ▸ Tile Window to Left|Right of Screen menu command instead of the older methods you are used to. Maybe for some reason those will work. But if the OS thinks Scrivener can’t do it, you may not see those commands at all.
  • Try a window management utility, such as BetterSnapTool. There are in my opinion better ways of achieving this result without all of the over-engineered shenanigans Apple partakes of. Imagine being able to drag any window at all, no matter if the program “supports it” to the left edge of the screen and it just snaps there—no waiting for Mission Control animations, no tedious long-clicks on little buttons or menu commands—just drag it. And that’s it! You could snap another window to the right, but you aren’t forced to either. You could also snap two windows on the right, at quarter screen sizes. Or other choices are available as well.

When trying to tile Scrivener in Full Screen mode with another app, the number of editor splits, and the visibility of the binder and/or inspector has an impact on whether you can put another app next to it.

I had a left/right split, and could not drag Messages onto Scrivener’s full screen desktop, but when I dismissed that other split, Messages fit. I had both the binder and inspector hidden at the time, but was able to show them after I had Messages sharing the screen with Scrivener.

My setup is almost identical, except I have the MB Pro M1.

1 Like

Interesting! I tried adding every horizontal element I could to the window to see if it would disable access, but instead of doing so it still allowed it, and then corrupted the window UI (until I reloaded the project).

I have no splits, no binder, no inspector - and still can’t tile.

The Window menu options are grayed out (as are the same options when I hover over the green dot).

If I exit fullscreen I can use the tile commands, but then I’m notified that nothing can be split with Scrivener, “no available windows” and “not available in this split view.” This occurs whether I make the attempt starting with Scrivener or with some other program.

While I appreciate the possibility that it’s a MacOS bug, it does seem rather odd that the only program that does not work correctly is Scrivener.

…and then it just started working…?

I had attempted with no binder and no inspector and it failed, but I just tried it again from non-fullscreen (which also failed before) and it now works on the second attempt.

In my experience, there is almost never a direct correlation between that and it not being a system bug. It’s more a matter of where the code comes from that determines that. There isn’t a line in Scrivener about this feature, and couldn’t be, as it’s a higher level window management thing, like Hide is, or Full Screen mode.

At any rate, it suddenly working is about my experience with it as well. :slight_smile: I’ve never figured out why it stops working, or why it starts.

Tiling to left or right works at my M1 mbp if I go to the maximize/minimize/tile icon, 3rd icon at the top left. I never heard of the method you’re talking about.

Scrivener has to be providing a minimum possible width to the OS, or in some way controlling how narrow is “too narrow” for the app. The OS is checking something about the app when deciding if it can tile with another app, and that value seems to be variable for Scrivener. Could the bug be related to how Scrivener reports its minimum width, as when the binder and/or inspector are visible?

I am not sure what the root cause is, I just filed the report I made as being reproduced with a small 12" screen that is scaled to maximum resolution. That should hopefully be enough to see what is going on a debugging environment.