Unable to Uninstall Scrivener

I’ve used Uninstaller included with Scrivener. It removed most of the Scrivener versions, but there are still some left.
I’ve tried removing it through “Apps & Features”, as well as through the “Control Panel”. But the following Scrivener version stay stuck, and don’t give me any options to delete them, nor it gives any error. Searching on the PC, also finds nothing.


p.s. looks like I had to uninstall previous version before installing or updating on top of any beta. My bad, now I know!

The free version of IObit Uninstaller sometimes can clean up problems like this, but be warned, IObit can nag you about things it wants to do that you may not want done. I check the “Don’t tell me again” checkbox on those messages.

Apps and Features won’t do it. You need to go to Programs and Features.

Believe it or not, that’s a different deal than the other one, and you can right-click and get rid of stuff that the Apps and Features option won’t do anything with.

Why? Ask Microsoft. No 'effing idea why there’s a difference, just that there is one.

If you are talking about Control Panel > Programs > Programs and Features, then I already tried that and it didnt work.


You did the right-click on the entry, then told it to delete the entry after the error message?

If that’s the case, man is that just another example of the inconsistency of Windows across different installations. I’ve literally seen different system behaviors between the same model of computer under the same admin regime, with supposedly the same software patches installed. It’s like Windows isn’t an OS, it’s a herd of cats wearing an OS costume, or something…

A lot of inconsistencies like this are the result of a corrupted user profile.

There are many common causes of user profile corruption, including poorly written apps that don’t follow the Microsoft guidelines, or the use of utilities that use undocumented APIs or directly mess with registry or file system entries in the user profile instead of using the established APIs. And the sad part is that you most likely will never know what app caused the problem, because they can cause issues that don’t show up for a long time and never affect the original application.

An easy way to check and see if profile corruption is causing your problem in this case is to create a new account with admin privileges on your Windows machine. Log out as your original user and reboot, log in with the new account, and now try removing the erroneous entries. If a corrupt admin user profile is the problem, this will keep Windows from loading that user’s registry hive and keep the corruption from affecting the uninstall functions.

In short, you suggest trying uninstall from different user? In my case didnt work. Still can’t delete,,, &

Edit: Solved. Not sure what fixed it. But while in another Win account: I download new version of Scrivener, then Uninstalled it. Went into Registry and searched for anything related to Scriver in : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall and removed it all. Then while restarting went into Safe Mode then back to Main account, and all Scrivener entries were gone.

You’ll need to create a new profile with administrator privileges. Any existing profiles are also likely to be corrupted if that is in fact the root cause of the problem.

I’d first try going to the folder for each version and using the uninstall file directly (uninstall.exe). This essentially bypasses any issues created by profile corruption.

You could also try booting Windows into Safe mode and uninstalling from there using either Apps & Features or accessing each version folder and double-clicking on the uninstall file.

Ultimately, the last resort is to delete any Scrivener entries manually from the Registry and files and folders from your drive, but I really wouldn’t advise that as a course of action unless you’re really familiar with the Windows Registry.

I have to admit it’s very concerning to me that every time I install a new beta I have to isolate myself from the internet and turn off Trend Micro Internet Security first so I don’t get told about all the harmful software (a virus and an “unauthorized change”) it has found, which then go on to block any attempt to install.

Any other Trend Micro users out there? Are you having problems like this?