Undo Jumps Cursor to Page Top

After installing the update, it seems that when you undo an action in the editor it jumps the cursor to the top of the page. You then need to scroll down to the point where you were before and click to place the cursor there again.

I don’t believe this happened before the update.

I can’t get that to happen in my tests. Undo doesn’t cause the buffer to scroll unless it needs to on this machine. Do you see this same behaviour is multiple projects? Try creating a new blank one and pasting a few pages of text, then testing there.

I don’t have access to the project right now but it was a new one I just created after updating to the latest version. I have no issues with projects created before the project. I’m wondering if the “Typewriter Scrolling in New Projects” option is part of the cause. I’ll check once I get back to the other project.

I’m seeing it work fine in a new blank project with a few pages pasted in for testing. I tested also with typewriter scrolling turned on and it worked as expected. It would snap the scrollbar if undo is called, but only so that the position of the undo action was centred on the screen. I wonder though if the newness vs. the oldness of the other projects is just a coincidence. The reason I asked for a test in a blank project was to see if perhaps it was a problem with this specific project rather than general or universal to your configuration. Since you aren’t seeing it in other older projects it’s probably safe to assumed it’s this one project.

I would try resetting the project’s UI settings first:

  1. Close the project
  2. Navigate to its location using Windows Explorer
  3. open the Settings subfolder
  4. drag the “ui.ini” file you see there to the Desktop or somewhere else convenient.

That will force the project to reset the UI settings next time you load it, and it will save your old UI settings where you dragged the file—in case that doesn’t solve anything, you might as well drag the ui.ini file back in and restore your old project view settings.

This issue still persists even upon the creation of a new project. It seems to only happen after a text color change. All other functions the cursor behaves normally after the undo operation.

Do you run any keyboard macro utilities, or have you made adjustments to your default keyboard settings? I’m wondering if perhaps Ctrl-Z is for some reason also configured to send a Ctrl-Home command.

Nope, no macros or altering my default keyboard. I altered the Scrivener shortcut for Strikethrough but I don’t think that would apply?

Okay, I think I see it. I was trying to change the text colour and then do other things and undo those things, but once I undo the text colour change itself, that is when it jumps to the top. Normal typing type edits don’t jump for me. Does this sound right?

Yes, that’s exactly it. I’m sorry my earlier explanation wasn’t more clear.

Great, I’ve written up the bug report. Thanks.

A post was split to a new topic: Document jumps to top

Any update on this?
I’m experiencing it too, in this scenario.

  1. Edit Style of a paragraph.
  2. Undo.
  3. Cursor jumps to head of document.

Really annoying :frowning: