Unwanted Bullets added

When I copy from one section that contains some bullets in it (even though the paragraph I am copying does not contain any bullets) to another section, bullets are inserted in every line in the section I am copying to. Not sure if this is clear, but the new sections become completely bulleted. Is this a setting I am missing?

I can’t reproduce this, could you post screenshots of the source file, your selection, and the target file after pasting? So long as I am careful to always select outside of a list area, list styling never copies over for me.

Amber, I already cleaned up the files (dumb), but if I can reproduce it, I will. thanks.

Found the behavior again. I had copied the paragraph starting “In Epistemic games…” which had previously been in the section that propagated bullets (it did not appear to have a bullet at start of paragraph when I copied it). After moving the paragraph,the bullet appeared in this paragraph, and it added bullets to the entire section.

This looks like an Apple bug, I’m afraid. All the bullet and lists code is part of the standard OS X text system, which Scrivener uses. The bullets and tables code is far from perfect to say the least, and hopefully one day in the far-flung future I’ll be able to replace the Apple code with something else.

In this case, what has most likely happened is that the text in the document at the place you pasted still had the bullet formatting (even if not bullet was present), so that when you pasted, the bullets got added. Try selecting all and setting the bullet style to “None”. This should clear the problem.


Thanks Keith. Scrivner is far and away the best software program for writing, and you and the support community are amazing. I’m going to give a talk to all of the grads in my department, and urge them to buy it.
I assume the procedure you are referring to is Text>List>Bullet/Number>none?

That’s the one, yes, but you can also access it from the lists button in the format bar.

Thanks for the kind words, and for wanting to recommend Scrivener to the graduates in your department - much appreciated!

All the best,

Sometimes Word mis-formats in weird ways when text is pasted. I’ve found that hitting cmd-Z one or more times after pasting sometimes undoes the mis-formatting, yet preserves the pasted data. I’m not sure if this will solve this issue in Scrivener, but it won’t hurt to try: cmd-Z is just the shortcut key sequence for “undo.”