Updated, text went crazy

Hello! I don’t know if it’s related to the update, but I installed it yesterday, and now my text went “nuts”.

I am not using any Style, but my text is supposed to look like a novel. Paragraphs indented like prose, sometimes dialogue.

The indented paragraphs now disappeared, all text is one “bulk”. I tried my usual fix whenever something is wrong in Scrivener: Documents - Convert - Text to default formatting.

But that doesn’t seem to do it. Now I’m stuck at a point where the text no longer automatically indents when I press Enter to start a new paragraph. I can do it manually by using Tab, but the indent is very big and looks weird.

How to get back to normal Scrivener, so I can write in peace?

Seemsl ike your Default formatting is lost, somwhow. In File > Edit > Formatting enter your preferred settings.
Select all Documents in the Binder and hit Document > Convert > Text to Default Formatting

Don’t use Tabs for indents, set the top marker of the Ruler to the left.

1 Like


For some reason, my text seems to «long to» change to No style, Courier Prime, Normal, Size 12.
Normally, I use Documents- Convert- Text to default formatting

This fixes it back to No style, Segoe ul, Normal, Size 10 and preserves the indented paragraphs. Looks nice.

But now – when I use the Text to default formatting, it changes No style, Segoe Ul, Normal, Size 10 and at the same time all the indented paragraphs disappear. It’s just big blocks of text.
The Ruler which I used to have on the top of the screen is gone.

Ruler in the Editor is View > Text Editor> Ruler.

Set the indent on the ruler in File > Edit Formatting.
Then Convert text to Default Formatting.

Don’t forget to set the default formatting you actually want, first. That can be done either Scrivener-wide or per project.

For some reason, my text seems to «long to» change to No style, Courier Prime, Normal, Size 12.

Well that sounds like you accidentally toggled scriptwriting mode on. If the icon on your text item is yellowish and your footer bar stats are replaced with element tips or something stating “General Text”, then that’s what is going on. Use the top menu command in the Format ▸ Scriptwriting ▸ submenu to toggle it back off, and look for any other yellowish icons in the binder to fix, too. You should see a message briefly appear, stating “Standard Text Mode” after doing so, and everything should be acting much more like you are used to.

But if that is not what is going on, then it sounds to me like your default formatting settings got a bit messed up in the upgrade somehow and simply need to be reset. Potentially this problem also impacted the text itself in that the formatting no longer works correctly anywhere. It could be less an issue of the formatting itself, and more with how it was stored and retrieved, but it’s hard to say without more testing.

There are instructions for easily setting your defaults again in this knowledge base article.

At a minimum I’d create an empty item in the binder somewhere, set up a paragraph precisely how you want, follow the instructions to set defaults, then go back to an affected document and try the conversion command again.

Thank you! Yes, it WAS the screenwriting mode that had been turned on.

Now of course, all my paragraphs are a mess, as I tried to fix them manually. Many of you mention setting a default formatting. How do I do this? And what could be decent settings for a “non-fiction book” or “memoir” type of text?

AntoniDol mentions File - Edit Formatting, but there is nothing like “Edit formatting” under Edit in my Scrivener. Using Windows.

One important feature that disappeared on me, is that it goes to indented paragraph on the next line when I hit Enter. How do I get that back?

Options, Editing / Formatting.
Set the demo text as if it was one of your paragraphs.
Once done, exit, and then do the convert documents to default formatting step anew.


Sorry for the confusion…

The article that I linked you to begins with the heading, “Setting Your Default Formatting”. That’s mainly why I sent it to you, since that is what you were asking about and it sounds like you already know how to do the stuff described in the rest of the article.

One important feature that disappeared on me, is that it goes to indented paragraph on the next line when I hit Enter. How do I get that back?

Refer to §15.7.1, The Ruler, in the user manual PDF for instructions on controlling indents. Note there are alternatives to the ruler given in the introduction to that section. I prefer the menu command stated in the first bullet.

Indent formatting isn’t really a “feature”, in the normal sense. You might be looking in the wrong places if you’re thinking of it like that. You’re describing what happens when you make your text red and then press return and continue typing in red text. Formatting continues when you press return, nothing mysterious or hard-coded about it. Same goes for where the tiny little arrow is on the ruler.

Thank you everyone! I think I’m on the right track now with the “Make formatting default” command. Then some manual fixing to do…


1 Like