Just gone from trial to purchased software.

Tried to update version, but get error message telling me to move the software to applications and reboot.

But it is in Applications.

What do I do?

Francis Corrigan

Thanks for buying! I’ve never heard of the Mac asking you to reboot after moving something to Applications - that’s strange. Just to make sure things are set up right, here’s what I recommend (I’m assuming you bought from us direct and not from the App Store in these instruction - let me know if not):

  1. Move Scrivener from Applications to the Trash.

  2. Re-download Scrivener from our website.

  3. Open the downloaded Scrivener.dmg file.

  4. Drag Scrivener from the DMG window to your Applications folder.

  5. Eject and trash the DMG.

You’ll now have the latest version of Scrivener and it should be installed properly so that future updates will work.

All the best,


thanks so very much, that worked well. It even recognised that I had already registered the product.

One more thing. I was trying to compile a book into Kindle format, and it takes the compile instruction and the output document name and location; then it visibly works through the page count. But then it simply stops, producing no output.

Am I missing something obvious as a novice?

thanks again,

Francis corrigan

Are you using <$BLANK_PAGE> at all?

If yes, see:


Slàinte mhòr.

Thanks for responding.

I saw your post earlier and couldn’t see any blank page in my document.

Anything you might suggest?


Hello, Francis.

Some ideas:

As a test, does the project compile to ePub?

As another test and for diagnostic purposes, do you get any Kindle output if you select the options to save the logs and source files? (See image below.)

Corrupt ASCII characters can cause problems. You can ask Scrivener to clean the project by loading your manuscript in scrivenings and then choosing Edit > Text Tidying > Zap Gremlins.

Can you compile just part of the manuscript to Kindle format?

Can you get any project to compile to Kindle format?

Are you using a default compile format, or have you got very specific customisations?

Where is KindleGen located, and have you re-established the link between Scrivener and KindleGen since the problem you had with the initial installation? (See “Reset KingleGen Location” in the image below, making sure that KindleGen is also in the Applications folder.)

Slàinte mhòr.


Thank you so much for your patient response. I worked through all your suggestions and eventually found myself back with your original advice!

Trying to compile a smaller section allowed me patiently to find the 4 chapters that would not compile. then as soon as I looked at each chapter individually I found a blank page in each one!!

Problem solved!

My Gaelic is not good enough to thank you properly!

Take care,


Good news.

Pleasure was all mine.

Slàinte mhòr.