Updating "No Style" in entire Scrivener file

I know that “no style” should be used for most text and that the styling can be changed in either Preferences or on a per project basis.

However, once I edit the “no style” default styling, how can I apply it to all text currently having “no style”? It seems that any changes only appear for new text or that I have to select the text and manually re-select “no style”.

Is there a way to update globally like it exists for all other styles?

Select all in the Binder and then Documents > Convert > Text to Default Formatting…

:grin:

Mark

1 Like

Thanks for the reply! But that would convert all styles to “no style”, removing all headings, blockquotes, code, etc.

I’m looking for a way to update “no style” based on changes to “no style”.

Example:

Like it works for other styles:

  1. H2 is added in text
  2. Font-family for H2 style is changed
  3. All H2s in text are updated with a new font-family

The same way, I’d like to:

  1. Have most text in “no style”
  2. Font-family of “no style” is changed
  3. All text marked with “no style” is updated with a new font-family

By default that command should work around styles, rather than stripping them. There is in fact option in there that will do just that, but it is off by default.

It’s worth a test at any rate, which is safe to do! Just take a quick Snapshot of a section of text that has a good mix of styles and regular text (⌘5), and then run the command. In inspecting the results, is that what you’re looking for? If so you can probably delete the snapshot, if it made a mess of things you can roll back the file to how it was—both from the Snapshots tab in the Inspector sidebar.

As for your checklist, that’s exactly how it works, though for no-style conversions you have more options available (you might want to keep tab stops from being overwritten for example). The command to reset your text to default formatting either pulls from your global settings in the Editing: Formatting preference pane, or each individual project’s settings in Project ▸ Project Settings..., under Formatting.

Hi Amber, appreciate the reply. Could you elaborate a few of the things you said?

  1. My checklists: H2 behavior works as written, but “no style” doesn’t show updates unless I manually select the text and re-apply the “no style”. Are you saying this should be updated automatically, like for H2?

  2. I’m not sure which command you referring to. Are you talking about what @xiamenese suggested? If so, that would affect the entire Binder, but the snapshots are on a per-document basis. Is there a way to take snapshot of the entire document or roll-back all documents after trying this out?

Thanks

Yes, I was referring to the command that xiamenese listed above.

If so, that would affect the entire Binder, but the snapshots are on a per-document basis. Is there a way to take snapshot of the entire document or roll-back all documents after trying this out?

In fact the command only works on selected documents. What that means depends on where your cursor is, basically. The only way it would impact the entire project is if you selected the entirety of the binder and ran the command—that would be your selection in that case. If you have one single text item loaded in the editor, then that would be your selection, and only it would be changed. If use it from within Scrivenings, where multiple text items are being edited at once, they would all be changed, so your selection in that case is multiple, while being in the editor.

As for applying No-Style again—yes that is one way to reset local formatting here and there. It’s not the best tool for broadly changing your default text formatting for that reason. It is better when you are using a multi-line style and want to break out of it, are typing in a character style and wish to return to regular text, or if you had some style applied and want to revert a portion of the text, etc.

Got it. Thanks for the replies and the information! :slight_smile: