upgrade problems

I’ve been trying to install the latest upgrade. When I input my password, it flips to a screen saying that it does not have permission to install and then asks me if I’m running it off a disk image. Then it tells me to contact my system administrator.

I don’t have the first clue what it’s even talking about. Can someone help?



Sounds like you need to repair permissions.

Open Disk Utility, select your boot disk in the column on the far left and hit the Repair permissions button. That’s all there is to it.



Hi and thanks for your reply.

Where do I find Disk Utility?

(I just plug it in and use it. I don’t understand it.)



Disk Utility should be in your Utility Folder in the Finder “Go” menu (or go to Finder and hit Shift+Cmd-U to open the Utility folder). If you can’t find Disk Utility, you can use Spotlight to look for it.

Good luck!


I’ve tried everything you suggested, and I still get the same error message. What else should I do?

Thanks for your help.


Now hold on a sec…

I recommended ‘Repair permissions’ as a knee-jerk reaction when you mentioned that “it does not have permission to install” – it was some time since I installed Scrivener.

But now I wonder why you had to input your password at all; it shouldn’t be necessary.

In fact, Scrivener installation is simplicity itself. First, you open the Scrivener disc image, if it’s not open already (double click on the scrivener.dmg file).

You should then see a new Finder level window with a corkboard background, containing three file icons. To install, you simply drag the Scrivener file (the leftmost ) to your Program folder. That’s it!

You’d probably get a dialog asking if you want to replace your current version, and you just click OK to that one.

If the above doesn’t work, please describe exactly all the steps you take when you try to install, and we’ll take it from there.

Good luck!



A couple of things a little bit techie, I’m afraid …

(1) Did you originally set up your machine yourself or did someone set it up for you? And is it set up so that there is an administrator account and your user account? You can check that by opening a finder window, clicking on the “System” icon near the top on the left, and then choosing the “users” folder. There should be your user folder, and a “Shared” folder. If there’s a third, that might be an “administrator”.

If there is a separate administrator account, when you try to install Scriv by dragging the icon as Spitfire31 says, it will come up with a dialog saying that the Applications folder is locked and offering two buttons “Authenticate” and “Cancel” (I think). You need to click on “Authenticate”.

Another little dialog will open saying that there is an older copy on your hard disk do you want to replace it. “Click Replace”.

Another window will come up with asking for the “Administrator” name and password … you’ll need to know those and enter them.

If you are the administrator, i.e. your user account was set up with administrator permissions, it’ll show your user name but you should still need your password. I don’t know why Spitfire31’s doesn’t; OS-X in my experience always asks for a password when you try to modify the “Applications” folder, (adding or deleting an app) as a safety measure against any software installing itself without you knowing.

(2) You must make sure you don’t have Scrivener running when you want to do the upgrade. The system won’t let you upgrade it if Scriv is open.

(3) I have found on Leopard that often I go through routine (1) – I have a separate administrator account – and it tells me I don’t have permission, I go through the routine again and it installs normally … and no, I haven’t mis-typed the administrator name and password. It seems to happen somewhat randomly.



Hi Mark,

This is not part of the advice to Rebecca, in order not to increase the confusion further. :wink:

I’m on 10.4.10 (and am not going the spotted OS for some time yet because of loads of legacy software and a nicely tuned system).

Anyway, on Tiger I have to input my admin password (I have no other accounts) if I use a wrapped installer.

But doing simple drag’n’drop install to the Programme folder like with Scrivener – nope, never had to input my admin password. I just tested again to make sure. And this goes for both my machines (G5 and MB P, both on 10.4.10). Having no experience of multi-account machines, I’ve just blithely assumed that’s the way it generally works.

Sorry if I’ve given misguided advice. Now I have another reason not to rush into 10.5…


I’m on Leopard, using an administrator account, and I’ve never had to input my password when just copying applications to the HD (though with a wrapped installer, yes). Then again, I have a separate Applications folder inside my user folder for third-party apps - I leave the root Applications folder alone, so it has just Apple apps in there.

If you copy into an applications folder in your own user area you won’t have to enter the password. I also have one, which I use for software that I want to try out only. On the other hand, all applications I know I want are in the root applications folder so they’re available on any account.


Just for the record, I always install programs in the root Program folder (10.4.10).

Still, I never have to enter my admin password for drag’n’drop installation in said folder.


Joey, I appreciate your comment and was concerned about complexity myself … but Rebecca is getting asked for her password and it seemed to me that that is one possibility. In which case it needs explaining.

I am really pleased I’ve moved on to 10.5 … this is the only issue I’ve noticed, and it’s hardly a hassle. 10.5 has brought me other major advances, like my FireWire audio interface is working again, which was unusable on any version after 10.4.8.


Hi Guys!

I FINALLY got it to install. (No. I haven’t been working on this for two days. I just took a shot at it every so often.)

I was fiddling around with it, just doing things to it to see if something or the other would work. On a whim, I drug that dmg thingy out of my applicatons folder and onto my desktop, and…it installed.

I’m sure all this makes sense to the rest of you. Me? I’m just glad it’s finally done.

Thanks for all your help.


Hi Rebecca,

Ah, we’ve found the crux of your problem - and you may not be 100% out of the woods yet. The DMG thingie is the package the application is in, kind of like a self-contained install folder. If you dragged it to your desktop and double-clicked it, then you’ll open the package.

However, while you can run the application from there directly, it’s not installed - your settings and so on won’t persist correctly. What you need to do is drag the scrivener icon from out of the window that opens when you double-click the DMG, and back into your Applications folder.

Then, just run scrivener each time by opening it from the Applications folder (or drag it to your dock).