Using Arrow keys in Scrivenings mode causes strangeness

In Scrivenings mode, when I use the arrow keys to attempt to go across a document boundary, the binder moves to the document but the cursor stays in the original document. At that point, I cannot use the mouse to select the document that the binder thinks the cursor is in. I can click to go to other documents though.

This also happens in a NEW and very simple project.

(These oddities also cause additional blinking cursors.) … 0.wmv?dl=0

I cannot reproduce this at the moment. More information?

I tried this with a new project that is just two test documents and nothing else. It does the same thing there. So I’m not sure what else to tell you. I assume you saw the video link I included above.

I appreciate you checking it out, anyway. Wish I could think of anything else to include.

Interesting. I watched your video (thanks for that!) and tried to recreate in RC9, but was unable to. Works fine for me.


Thanks Jim. I’m on RC9 also (is it even possible to continue on an older one? I never tried).
I am using HiDPI, but I’m quite sure that would not make any difference.

It’s low priority though. No big deal.


Hi Mark,

I’m using the standard/non-HiDPI version (as is rwfranz, at least based on the post linked below), and haven’t a clue whether it would make a difference. :slight_smile:

[url][LH4669] Not sure if this is a bug, exactly - Misplaced notifications - #19 by rwfranz]

As you experience the bug and we do not, we’re just gathering differences in environment and process, as input to L&L’s debugging.

If I were experiencing this bug, it would be a big deal to me, as I try too maximize navigation by keyboard over mouse. So I am very grateful that I’m not. :mrgreen:


Could you all please share:

  1. Where the notification appears,
    Not a notification… the binder jumps to the next file but the actual editor remains on the same file. (see video link provided above)

  2. which version of Scrivener you are using (Hi-DPI or standard), Hi-DPI… (RC 9) — Version: Beta (1017023) 64-bit - 14 Aug 2020

  3. your screen resolution,
    2560x1440 (both screens)

  4. Windows display scaling setting,

  5. Windows version,
    Win10 Home, 64 bit, 1909 OS build 18363.1016
    ASUS a5m97 MB, 16GB RAM, AMD FX-8350 Eight-Core 4GHz, 240GB Crucial SSD w/ 58GB free

  6. and whether you’re on a single or multi-monitor setup?
    both screens are 2k - Using NVIDIA GeForce GTX 1050

While I was not able to reproduce what you are seeing - using the non-HiDPI RC9 - I did discover an oddity when using the arrow keys and having Show Titles in Scrivenings turned on. (View->Text Editing->Show Titles in Scrivenings) Everything starts out okay and using the down arrow switches from one document to the other in the binder but, as soon as you have progressed in the Scrivenings to the point that the first document title is no longer visible, trying to use the up arrow to go back to the first document’s title the cursor goes up but the title does not come into view. The cursor is at the end of the title line, but the only way to see it is to use the mouse to scroll up. Makes me wonder if that is not related to this oddity the OP posted. GoMach, can you try toggling off the titles and try your test again?

Weird. Mine was already off. So I turned it on and it acts strangely. I didn’t try as many combinations. But it did do odd things with the binder, and once allowed me to arrow down from one document to the other, but not back up. I turned it back off and it reverted to the same behavior as before… never allowing arrow keys to get to another document (see video link above).

Loaded up my Surface Pro with the RC9 HiDPI version and was able to reproduce what you originally posted - sort of. I was able to move into my second document, but there is where it stopped. I had to use the mouse to scroll and click into any other document, and you could never tell where the cursor was as there were two or three blinking in various places in the visible document areas. It was worse when the Titles were on. I had to use the mouse in the Binder to actually select a document. This is definitely a bug and would be a real problem for those that prefer keyboard controls over the mouse.

Wow, interesting. I appreciate that follow-up. Yes, it is a minor problem for me, but I could see how it would be major to some. I often try to cursor across document boundaries, then recall that I must use the mouse (clicking on the current document first, then clicking on the document to which I want to go)

Thanks Jestar.

Thanks, all of these notes have been filed to an existing ticket that covers cursor movement between scrivenings.