Using scriv from dropbox on vista... too slow?

Hello fellow scrivener users.

I’ve taken the advice of these forums and have been using dropbox to sync my scrivener project between my uni computer and my home netbook.

It has been great. Much simpler. No more incompatability problems (I was previously using a thumbdrive and DriveHQ… which sucked).

But today, my uni computer kept crashing whenever I used internet explorer. The IT guys reckon it was Scrivener but I kept saying scrivener is a local programme and doesn’t use the internet. But then I thought I read somewhere that dropbox accesses the internet via the same ‘methods’ (not sure of the right terminology) as internet explorer.

THe more I thought about it, the more I realised my computer has been running more slowly since installing dropbox. As Scrivener appears to save after every change even just one word, dropbox seems to be updating after every change too. Which may be why the computer is running slowly and internet explorer crashing??? I have no idea. ANyway, I can’t get any help from IT as they think its my fault for running Scrivener, a beta program…

I just had a vista update today too, which may have affected things…

ANyone have any thoughts on this issue?


Scrivener autosaves every two seconds by default, which means that every two seconds it’s writing changes to files in your Dropbox–which means that if your computer is connected to the internet, Dropbox immediately begins syncing those changes with the cloud. Ergo, you have fairly constant network activity, which means it could slow down your internet browsing and other downloads/uploads. (As for actually crashing IE, I don’t see why it would do that, but then IE has so many issues to begin with that it would hardly surprise me.)

Since this isn’t related to Scrivener being in beta but just to the auto-save, it’s not something that’s going to change with the official release. There are a few basic ways to get around this:

  1. Change your auto-save time to something less frequent. This will make Dropbox not sync as often, but it will also obviously not save your work as often, so widens the holes in your safety net. Note that if you’re an incessant manual saver, every time you hit that “save” button you’re going to make Dropbox start syncing.

  2. Pause Dropbox syncing while you’re working–you should be able to do this just by right clicking it in the task bar and choosing Pause Syncing. (Er, I’m not on the Windows machine at the moment, but I think that’s it. Something like, anyway.) Your changes will still get written to your local machine, but they won’t be synced with the cloud and your other computers until you un-pause, so make sure you do that and allow Dropbox time to complete the sync before you log off. Also note that of course it will pause all Dropbox syncing, so if you’re just poking away at Scrivener while you wait for your friend to dump something in your Dropbox, that won’t work so well.

  3. Don’t work straight from Dropbox. Move your project file to your desktop or somewhere else on your hard drive before you open the project, then open it and work on it allowing it to auto-save regularly, and then when you’ve finished, close the project and move it back to Dropbox and allow Dropbox to sync it all. Similarly, you could just make a backup of the project when you’re finished and store that in Dropbox, then move that out and unpack it when you’re ready to start working, etc. That works really nicely with zipped backups, although at present I know there’s an issue with making zipped backups via Scrivener so you might want to hold off on that (or do it manually via Explorer).

The last example is how I work–I just store my zipped backups on Dropbox and then move them out and unpack them to a local “Scrivener Projects” folder to work on them, then zip them up and store them in Dropbox when I’m finished. I prefer to sync the zipped projects since they’re treated as a single file vs. tons of individual ones, so it’s less prone to suffering corruption from tiny network glitches (which I get all the time), and I don’t have to deal with the constant network activity but I can still get immediate notice when my collaborator updates a file in our shared Dropbox. But pausing works well for a lot of people who don’t have that specific need–just make sure you turn it back on when you’re done and let the whole project finish syncing before you go!


Thanks for that, I’ve worked it out with IT> Seems to be OK now I’ve reinstalled dropbox.

I have been working by pausing dropbox which is OK. I’m a bit reluctant to do the zip thing as I’m not in a good space brainwise at the moment and I know I’ll screw it up… one of the reasons I swithced to dropbox was so I didn’t have to do that. I only use dropbox for syncing between computers, not collaborating at this stage so sohould be OK. THe only problem is when I have to suddenly leave work (happens often… DH at home with baby and updates me on when I need to come home to feed) and dropbox seems to take forever to connect and then sync. I end up having to leave my work computer on which isn’t ideal or sociall acceptable in our workplace!

I feel like Scrivener is saving more often than every 2 minutes. Maybe I should check that again too.

THanks again


The rest interval for auto-save is two seconds not two minutes. It waits until have paused working for two seconds, and then saves. Cranking this value up in your General options tab is not a bad choice to make if you intend to do a lot of work right on Dropbox. Do keep in mind though that it is an idle timer, not a static timer. It waits until you pause, so that optimally you don’t start typing while it is saving, causing lag. Since this is an idle timer, you don’t actually need to boost it much at all to make a big difference. I would try moving it up to ten seconds and see if that works better, and then fine tune it from there up or down in two second increments until you strike a good balance between keeping things saved, and not constantly hogging bandwidth.

Whoops, sorry, I should’ve clarified that it was idle time, not constant. I only ever pay attention to it when I’m twiddling my thumbs not typing. :wink:

THanks this has improved things immensely!