Using scrivener as a french writer

Hi everyone,

I have been using Scrivener for a week now and I really appreciate it. However, I meet with some difficulties that may be language-related (I solely write in french). It also could be that I still need to master some aspects of the software… :slight_smile:

  • Scrivener doesn’t automaticaly add nonbreaking spaces before “?”, “!”, “»” or after “«”. Spaces are actually optionals in the cases of “?” and “!” but a checkbox option that would take care of that would be great! Adding the nonbreaking space manually (ctrl G, ctrl W) is quite tiresome. For now I use a logitech G-key that adds the space then the character.

  • My first compiles (I used the basic parameters) “translated” my nonbreaking spaces into actual spaces, not thin spaces. They weren’t broken, so they still were nonbreaking spaces, but I expected them to be thin. It also translated my french quotation marks (« ») into english ones (" "). I figured I would need to explore the compile options further, which I haven’t had time to do yet.

  • Scrivener marks as errors many uses of hyphens in inversions. e.g. in French: « Je suis déjà rentrée », dit-elle. will be marked as an error though I did select the french dictionnary. It happens with many inversions.

About those things, any advice is welcome. Still, the software is great!
I will update this post as I encounter anything else worth mentioning.

Edit1: in the compile options: transformations / conversions de texte brut / 2nd item is “Remplacer les tirets quadratins en traits d’union”. --> it should be “tirets cadratins”.

Edit2: the dictionary seems to lack some common vocabulary (e.g. “investiguer”). It’s not much of a problem, but those red underlines always take me by surprise… :slight_smile:

Thanks for the feedback! Currently Scrivener uses the Windows port of the Aspell dictionaries, but we’re aware they’re rather out of date and lacking for a lot of languages. We’re looking at other options for the next major version of Scrivener.

We’re aware of the missing non-breaking spaces and do have that on the list to address in the future. I’ll add your note about the optional cases, although that may be pushing what we’re able to handle, so no promises on the checkbox. :wink:

By your first edit (thanks for the typo catch!) it looks like you found this, but to prevent the quote conversion, make sure that in compile’s Transformation settings, you leave “Straighten smart quotes” deselected.