v1.9.9 reports "Scrivener is not running from its installed location"

I was pleased to see v1.9.9 available, but am less pleased since installing it.

If I double-click on any .scrivx file, I get a dialog box saying:

Scrivener is not running from its installed location.

Runtime location: "C:\Program Files (x86)\Scrivener"
Installed location: <path to .scrivx file>

Scrivener should be started from its installed location. If Scrivener isn't running from its
installed location, you will not be able to update Scrivener and your registration might
not be recognized. Please, run Scrivener from its installed location, or uninstall and
reinstall Scrivener to avoid getting this message.

v1.9.9 appears to run correctly despite the dialog box.

I’ve tried uninstalling & reinstalling, with no difference. The only way I’ve found to get rid of this dialog box is to create a shortcut to the .scrivx file, then change “Start in” for the shortcut from the .scrivx file location to “C:\Program Files (x86)\Scrivener”.

I’m running Win7 64-bit, and had no such problem with Scrivener v1.9.7.

I’m also getting this error. Running Windows 10 Pro, Scrivener for Windows v. - 03 Oct 2018
Scrivener seems to function OK, but the error has me concerned regarding file integrity.

There is no installation of Scrivener in the documents folder. I’ve tried uninstalling and reinstalling Scrivener, but I still get the error.

(Post edited to insert below info)
My active Scrivener projects reside in DropBox where they are also accessed by the iOS version of Scrivener.

Thanks for any help here!


This is VERY weird. I don’t have the problem. But, maybe this MIGHT help, and can’t hurt.

Find the shortcut that is used by the Windows Start menu. To do this with Windows 10 right click on the icon that would launch it from the start menu, select more / then go to file location.

Right click on the icon and enter this to the start in: entry:
“C:\Program Files (x86)\Scrivener”

Assuming it was blank.

Thanks, Steve.

I gave your suggestion a shot but am still getting the same error. [The start menu shortcut was linked properly to the folder C: / PROGRAM FILES (x86)/Scrivener ]

I’ve tried launching Scrivener from that folder with the same result. Scrivener seems to function properly, but this little hitch has me concerned.

I’ve been using the Windows version of Scrivener since its first release and haven’t seen anything like it. I’ve never moved the .exe file from the program folder. Knock wood it’s just a pop-up window I can ignore for now, but I will be running compile and exporting after each session.

Thanks again!

  • Another Steve

UPDATE 10/25/2018
I’ve been ignoring the “Scrivener is not running from its installed location” warning and everything seems to function normally. No crashes or any other errors to report.

I’m experiencing this problem too (well, my Writer is - I’m just the sysadmin).

Could it be something to do with the account used to upgrade to 1.9.9? In my case, the PC has a separate account with permission to install to %PROGRAMFILES%; any admin tasks are either done in that account (as with the Scrivener upgrade) or, if performed from an unprivileged account, need an elevation prompt (which then requires the admin account password).

The Scrivener upgrade didn’t try to elevate. Also, I recall that when my Writer first installed Scrivener they ended up with it installed in their home area because of a similar non-elevation issue.

I’m still having this issue, but Scrivener seems to run OK. I did install in a user account, not the admin account in Windows 10 Pro. I just ran the uninstaller and reinstalled selecting “run as administrator,” but I’m still experience same error. Launching directly from Program Files (x86) / Scrivener makes no difference.

I have a hint why this happened to me.

In my case, the last beta version (10) was installed in \users\username\Documents\Scrivener as a limited user.
After that, I activated the OneDrive online folders. It change the Documents folder to \users\username\OneDrive\Documents\Scrivener

On top of all, I reinstalled the Scrivener as an local Administrator, done in \Program Files\Scrivener

I suspected that Scrivener isn’t foreseen that the installation folder for a limited user can be changed by OneDrive or the uninstall of a limited user isn’t clean up after.

By the way, I didn’t pay attention to the post title. My buggy experience was with the Windows Beta 10