V3 Bugs PDF Table of Contents a others

While converting a book that was started with V2.8, I created a new V3 project “General Non-Fiction” and tweaked it to use hierarchal $ numbering. Then I add two chapters and created a “Test and Scrivener Examples” page that had footnotes, styles, and all sorts of tests of content that were in the existing V2.8 pages, as well as “Styles” for V3. I then worked on the example book as both PDF and Kindle MOBI output. I tried EPUB3 and KF8 but quickly realized that there was more to do using these than a simple conversation.
Below is a list of bugs that I haven’t been able to solve or workaround.
Table of Contents Bugs:
1. I have a hierarchal nested non-fiction document. There may or may not be text inside the Chapter-level folders. If there is not text when the TOC is compiled the page number for the chapter is “??” but the included documents have page numbers. If there is text within the folder the TOC page number is correct.
2. TOC page must be assigned “As-IS’ Layout and not “Contents” layout to work. Note: The 20pt extra vertical spacing after each TOC entry seems way too much, but can easily be adjusted by the author. It would be nice is the horizontal space was as easily adjusted.

Misc Bugs from “Test and Scrivener Exammples” document.
Note: The two-m’s in Examples above is intentional. It was for testing which searches looked at binder titles.
1. “Insert => Horizontal Line => Centered Line” is Missing in PDF output.
2. An “Insert Break => Page Break” in the middle of a page inserted two breaks.
3. An image inserted via the <$img …> tag doesn’t have the correct vertical spacing and covers the text above. Image of the issue is below.

If there is no text, it is possible that the link is pointing to a document that doesn’t exist within the MS. In that case you would see the “??”. If there is a title or anything else inserted, though, the page numbers should show up fine.

The built in non-fiction Format is designed around not having a hierarchical ToC, and to have spacing between entries, as you have noted. These formats are just a base. You are free to edit them for your own purposes. (You could equally use “Preserve Formatting”, of course.)

It is very difficult to test any of this without the sample project.

This just inserts a number of centred underscores. They are present and correct when I export to PDF format.

No, it only inserts a single break.

I would check your line spacing settings there. It looks as though you may have set some “Exact” or min/max line spacing that could force strange overwriting lines. Again, though, a sample project would help me determine what is going on.

All the best,