V3 - Scrivener randomly freezing during start

Hi everyone,

I started using the new version yesterday, and I experience a strange issue on Windows 7. Scrivener always opens fine after starting my computer, but if I close and open the program again it may freeze at start. I’m not sure if it occurs after a certain amount of time without using it. The program’s window is all white, and stays that way no matter how long I wait. It will then open just fine if I restart my computer.

Am I the only one having that problem?

Hi everyone,

I still have the issue, and can’t pinpoint what causes the freeze. What could cause it, does anyone have an idea?


Based on the timing, it sounds like there may be some other software that starts up on your computer and is preventing Scrivener launching correctly at the later point. You could try booting in Safe Mode with Networking and following the same steps there to see if the problem repeats or if Scrivener in that case loads normally after being closed and reopened (with generally the same timing and method as you’d normally use). If it works there, take a look at what other software and services you normally have running on Windows, whether it’s something you yourself launch regularly or something that runs automatically during startup (but which may not have fully initialized at the point that you first launch Scrivener). Opening the system configuration settings (type “msconfig” in the Windows Start menu search bar and press Enter to launch it) will let you see what various programs you have and enable you to temporarily disable some from the next boot.

You can also try launching Scrivener with logging by navigating in File Explorer to Scrivener’s installation folder, right-clicking the “ScrivenerLog.bat” file and choosing Run as Administrator. You should see a separate window open and printing out the log as Scrivener launches (and once you close Scrivener the log will be saved in a “log” folder within the Scrivener directory). The last line in the log at the point that Scrivener hangs may indicate an error.

I have a similar problem, with the difference that Scrivener 3 always freezes on startup. It shows the project choose screen, but that’s it.

When I started it with the logs enabled, it goes well up to a point after loading the fonts, then repeats the following error over and over:
Critical: File: Line:0 Function:QSettings: RegEnumValue failed (No more data is available.)

This starts just after logging the SSL information.

The line indicates Scrivener isn’t able to access the registry correctly. Assuming you’re already launching Scrivener from the same account that installed it, you could try setting Scrivener to run in compatibility mode; this has helped some other users work around registry problems. To do this:

  1. Right-click Scrivener’s .exe or desktop shortcut (however you usually launch it) and choose Properties
  2. Select the Compatibility tab
  3. Tick the option to “Run this program in compatibility mode for” and select the highest Windows version available (in some cases, it may be the same version you’re already running normally)
  4. Click OK

Then launch Scrivener and see if it starts up and runs properly. If it works, there’s no harm leaving it in compatibility mode.

Looks like I had a registry access issue (Found the same error in the log than clombard), and these steps apparently solved it. Thank you very much, MM!

It starts up without problems now. Thanks so much MM!

Cecilia Lombard