Vanishing document

Pretty new user here, so this could be user error, but… I usually use the main compose window but just did a little writing in the pop-out compose window for the first time, saved/closed, and now I can’t find the document.

I know it saved! It appears in a search on a text string (from the top searchbar), and the search results indicate that it’s in \Draft\pages in my current project …but it doesn’t show up on the corkboard in \Draft\pages, nor in the binder, nor can I open the file by clicking on the search result.

Have tried restarting, navigating around with the arrows, tearing hair out, etc. Any help very much appreciated!

If what you wrote shows up in search then in upper left corner of editor window when file is open right click on icon in title and will see option to reveal in binder and this will highlight file location in the binder allowing you to find the file

Alas, the file is not open - I closed it and now can’t open it again, because I can’t find it anywhere.

I can see the file path in search, but the file doesn’t appear when I look at that file path in Corkboard or Binder.

What do you mean by “file path” ? What search engine are you exactly talking about ?
Normally, a search just isolate the documents corresponding to the search criteria in the binder, or in a list if using the quick search.

Inked2022-02-17 13_12_36-Window_LI

Perhaps when you say “popup” you actually mean the scratchpad ?

2022-02-17 13_06_49-


Argh, sorry, I can’t post a screenshot or a link, maybe cos I’m a new user?

  • The document doesn’t appear in the main search at all.

  • It does appear in the quick search, and when I mouse over it in the search results list, a tool tip appears that says “\Draft\pages,” which is where the document allegedly is.

  • I have the Corkboard and Binder open to \Draft\pages and the file does not appear in either

(I’m sure the screenshot would help here, sorry, maybe I can email it to you?)

Ok. In quick search (where hovering tells you the file path) click on the reference to your file.
That should open it in the editor.

Then right click on this icon,

Inked2022-02-17 13_38_49-Window_LI

and chose “reveal in binder” as GoalieDad said.

Keep in mind that the corkboard doesn’t actually show a selected file, but rather its sub-documents.

Doesn’t work! If I click on the reference to my file, the list of search results goes away, but no document is opened.

Further data point: I’m trawling around in the Windows file explorer and I found the RTF data file for the document ([my Scrivener project] > Files > Data > [long nonsense string] > content.rtf). It looks similar to the other documents in my project, it just doesn’t seem to have gotten indexed in whatever way would make it appear on the Corkboard or the Binder.

Double click on it.
It should open it in word, or in wordpad → whatever.
From there, you should select all text and copy.
Create now a new document in Scrivener, and paste your copied text there.

Hopefully after that you can just forget it ever happened. :slight_smile:

You might have to delete stuff such as : <$Scr_Ps::0><$Scr_H::2>
but at least you’ll have your text.

I honestly have no better idea, nor any clue as to what might have happened.

That’s exactly what I’m doing! Honestly I breathed a sigh of relief as soon as I saw the rtf - I can handle any type of frustrating mystery as long as the words aren’t gone, and they’re not.

Thank you for your help!

I just tried it, and if you import it instead :

…it removes all the annoying stuff.