View > Text Display > Hide Markup does not hold it's setting

In File > Options > Appearance > Textual Marks > Options > “Hide Markup” hides, I ticked the box alongside Comments. That done…

I use comments for different purposes in the Inspector (normal comments are yellow, red herrings are Red, backstories are Green and foreshadows are Grey) colouring the background, as required in the Comments tab. At the same time, I have complimentary font colours which serves the same purpose., in the editor.

So, what I’m saying is, I don’t need markup colours in the editor, I simply want to hover over the fonts to see the comments. But I do need the colour differentiation in the Inspector’s Comments tab.

Using Alt+Shift+H, I was able to switch-off all markup colours in the editor.
But they come back, and I don’t think that’s the intention, unless a user presses Alt+Shift+H again.
At first, I assumed it was happening on exiting a project and returning to the same project again.
I thought it was the case because every time I came back into Scrivener, I clicked onto the Manuscript folder and selected the Comments tab from there.
Clicking on a Comment in the tab takes me to the comments in the editor, highlighting it in Scrivener’s default highlight. All well and fine. But clicking away from the comment, the markup colour comes back.
Then I found that if I came back into Scrivener and manoeuvred my way through the folders and documents to a comment, the comment markup colour had not returned in the editor text. That looked like a solution, but…
I finally narrowed it down. Clicking on any folder in the Binder, then selecting the Comments tab in the Inspector and clicking on a Comment from there, moves to the comment in the editor, highlights it and when I click off it, the highlight disappears, and the markup colour returns.

To get rid of the markup colour requires pressing Alt+Shift+H twice (don’t know why, but it is what it is).
If I click on other comments in the Inspector within the same folder, the markup colour does not return if the markup attribute has been switched off.
But as soon as I select another folder in the Binder and then click Comments tab in Inspector the bad behaviour returns to the editor.

Since Manuscript is the top of the hierarchy clicking randomly on comments within the Comments tab in Inspector works fine. But as soon as you select another Folder in the Binder the unwanted markup returns in the editor.

I tested in different projects on 2 machines, one running 3.1.4 and the other 3.1.5 release versions, and also with the Interactive Tutorial project.

What I’d expect to see is once the choice has been made in File Options, the View > Text Display > Hide Markup command should stick and not revert to its former state without been told to.

I think the issue is related to scrivening view :

As you can see in the right editor, hide markup is on, as the second line doesn’t show as being commented on.
In the left editor, hide markup has no effect.

@Kevitec57 You should answer this one question :
Does Hide Markup actually toggles itself off, in the MENU, in your specific case ?
(For me, that’s as close as I could come to reproducing your issue. In a editor showing a single document, hide markup sticks to the menu setting, and works as intended.)

Yes. You’re right. Thanks.
More than anything, I’d like it to work correctly and not revert in Scrivenings view.

So, you are in scrivening view, right ?

It sticks to the setting in the menu, but displays the highlight even so, in scrivening view. (?)

I’d say it is a bug indeed.

[EDIT] Now that I think of it, it is likely the very same bug that prevents scrivening view from sticking to displaying the label’s color in the documents’ titles.

Yes. I’m in Scrivening view.

I was just seeing it, approaching the comments via the Inspector.

You approached it via the Binder and I believe you nailed the hassle. Individual documents (scenes) look as they should without the markup, but the same documents collected in Scrivenings view have the markup.

To qualify my initial thoughts, if I click on Manuscript, the markup appears. If I turn it off Alt+Shift+H (twice), it stays off for all access via the list of comments… all Comments are probably seen as belonging to Manuscript.
Same behaviour if I take a Part and approach from Comments. And then Chapters.

I use label dots in the Binder, but only for my scenes. It hasn’t stopped working.

I mean this :

It doesn’t stick to the menu setting either.

(That’s an old one.)

Ok, thanks. I don’t use that.

My point being that, likely — (for the big nothing that I know of coding and designing a software) —, they have a common buggy root.

1 Like