View > Text Editing > Page View Doesn't Work With Scriptwriting Format

Hi All,
For some reason, page view doesn’t work for me on windows ever since I’ve been using the Win 3 Beta version (for about a year). This happens with the scriptwriting format. It doesn’t happen in regular text formats I tested.

This is what I get.
[attachment=0]Screenshot 2020-12-07 092902.png[/attachment]

Check your page size and page margins. Attached is the Page View mode in my tests:

[attachment=0]Screenshot 2020-12-08 01.01.52.png[/attachment]

You may also try switching to the Non-HighDPI version and check how it works for you.


I’m not getting that. When I am not in page view, my page size and margins are “normal”. When I switch to page view, the page size does change. When I check my page settings they are set to letter as expected. How do I change page size in my viewport?

[attachment=0]Screenshot 2020-12-09 103452.png[/attachment]

I will note that when I look at the print preview it exhibits the same traits as the error in the page view. My printer is a standard printer set to letter. No scaling applied.

If you open File > Options and select Page View from the Appearance tab, you’ll see what it’s currently basing the Page View size on. This could be either the Page Setup settings or the compile settings. If it’s currently on the latter, it may be that your current compile settings are using a different page size (e.g. a custom paperback novel size). That can be changed by choosing a different compile preset or editing the one you’ve currently got selected under File > Compile, but for the moment you could just try switching the Page View options to base the size on the Page Setup, which you already know is set to what you want. Does doing that fix the view in the editor?

Sorry for the delay in response. SUCCESS.

So I did follow your lead on this and it fixed the issue. As per “MimeticMouton” here’s what I did if you need the answer to this issue:

File>Options>Appearance>Page View
From there: Change “Base page view size on:” To “Compile Settings”

And that worked! I didn’t know that existed.

And interestingly enough, if I go back to, “Page Setup Settings”, it fixed the original problem I posted above. So there must have been some old pref that was being loaded.

Also, on the PC it appears the Page Setup Settings are more accurate than the Compile Settings.