Viewport jumps back to the origin after editing

So, the beauty of this software is that the canvas is limitless in size.
The annoying jumps happen, as I recently found out when editing notes, outside the area which is originally in viewport when the document is created.
I tried switching modes (selection, move). Never tried re-installation (I use this software daily and haven’t got the time to do that).

Any tip to fix, suppress or workaround? Is this happening only to me?

i’m having the exact same problem. i haven’t found any fixes yet. for me the screen jumps up even further than the normal view, to the point where it snaps back down to neutral if i try to move it at all.

I have found out that when the “Zoom” slider is in default position the problem doesn’t show up.

Bumping this thread, as I’m having the same issue. I don’t remember this happening in the previous version of Scapple I had, but now it’s super difficult to work around. If I ever zoom in on my canvas and want to work on a section near the top or bottom edges, anytime I scroll vertically or horizontally, the view jumps/snaps away from where I’m working. If I do cmd+shift+8 to zoom in on a selection and only work on that specific section, it doesn’t mess up. But as soon as I try to scroll up/down or left/right or try to zoom out a bit to see more of the canvas, the issue re-appears. It doesn’t happen as much if my zoom slider is reset to default zoom, but it’s impossible to work at that level once the canvas gets past a certain size because the text gets way too small. And sometimes it still does it even when I’m at default zoom level. If I do cmd+9 to zoom out to show the whole canvas, if I scroll up a little bit, it’ll jump.

Any help/insight on how to resolve would be greatly appreciated!

Hi all, Rob from support messaged me saying that they’ve seen a few reports of this bug but haven’t been able to replicate or fix it on their end. He suggested that I try deleting the scapple preferences file to try to fix. I tried but it didn’t fix. He also suggested perhaps downgrading back to version 1.3.4, which DID fix the problem. So perhaps that’s a stopgap solution for now. You can download from the literature and latte website

1 Like

Hey Supermonk thanks for a very helpful update!
I’m also still having a hard time due to the issue, read your latest post and considered downgrading the app, but duh, ver 1.3 doesn’t support Apple M1 chip! I’ll stick to buggy ver for now…

The same issue happens to me with the version 1.4, not with the version 1.3.4.

I found a way that seems to ‘fix’ it with version 1.4. I completely zoom out, add a note (for example, a simple letter) in the lower right corner, then zoom in again.

If I remove this ‘note’, the issue comes back.

(Running on Big Sur 11.5.1)

Thanks for posting your workaround, @PerlinP, I hope that helps anyone else seeing this.

We’ve got this one the list to take a look at though, thanks to everyone for the reports.

Yep I’ve just started noticing same bug when zoomed in. Think it might have happened since I upgraded to Monterey (12.1) from Big Sur.