Want Default View to be Scrivenings, Not Corkboard

New here. Tried to search for this, but can’t find it so sorry if this is a repeat.

Up until a week or so ago, when I clicked on “Manuscript” it brought up the Scrivenings of the whole document.

Now, when I click “Manuscript” it brings up the Corkboard. I can click the icon for Scrivenings and see the whole document, but I want it to default to Scrivenings when I click “Manuscript.”

Not sure what I did (if anything) and can’t figure out how to change it back.

Thanks in advance.

Lock a folder or container to a Group View Mode by right-clicking the Icon on the Title bar of the selected Folder and choosing the bottom option of the Context Menu.

GemLockGroupView

1 Like

Thank you.

Does it always default to “Corkboard” view after you’ve added a certain number of words? I didn’t have to do it before and I didn’t change any settings that I can recall.

I think it remembers your last selection.

1 Like

Well. I keep selecting Scrivenings and it keeps defaulting back to Corkboard.

Anyway, locking it works for now.

Thanks so much!

1 Like

It may depend on how you are selecting the Draft. There are a few bugs left in how the group view mode is sometimes ignored entirely and always drops back to Corkboard. One of them, to provide an example, is to use the Next/Previous Document buttons (on the right hand side of the editor header bar) or the associated keyboard shortcuts.

In the “Binder,” I click “Manuscript.” For the first six weeks I used Scrivener, if I clicked “Manuscript” it brought up the Scrivenings of the entire manuscript. Then, magically (seriously - I don’t think I did anything) one day when I clicked “Manuscript” it brought up the Corkboard instead.

I do think it changed after I updated. Is that possible?

Just out of curiosity, if you unlock the view mode so it works normally again, click to a subfolder to make sure you’re in Scrivenings mode, and then back to Draft, does it work now? I’m wondering if maybe the setting got stuck on somehow.

There isn’t by the way a limiter, it’s designed so that if you make a session that is so long it takes forever to load, you can just click anywhere else to cancel. So there wouldn’t be a need for something like that.

When I unlock the view mode, it goes back to showing me the Corkboard when I click “Manuscript.”

Just dawned on me to mention that I’m using the “Nonfiction Format” template. Not sure that makes a difference.

Thanks for everyone chiming in. Don’t mean to seem ungrateful. Just new and confused.

Interesting! Well, if this project is something you could send to technical support, we could take a look at it and see what is potentially causing this behaviour internally. It if goes from not working, to working, to not working again with a 100% rate of reproduction, then the chances are high it’s something we can debug and fix.

In the meanwhile the lock setting should suffice to keep things working the way you want.

1 Like

I’d be happy to do that. How? What is the procedure? Export the project? Send the project file? send it where?

As for where, the link I provided in the previous post provides our email attachments.

As for how: easiest approach is to use the File ▸ Back Up ▸ Back Up To... menu command, with the Zip option enabled. That backs up the project into one compressed file that you can attach to email.

1 Like

To whom do I email it?

Oh! I see the link now. Thank you. I will email it.

Please confirm if this behaviour was ever resolved?
I have two fiction projects that also default to Corkboard when clicking on Manuscript, irrespective of me leaving the Scrivenings active when clicking away - it only happens at this level. Yet the Scrivener Interactive Tutorial project and anything new I create from the Scrivener Novel (with Parts) template remembers Scrivenings mode after I’ve clicked elsewhere and back to Manuscript.
The projects aren’t that big, around 105,000 words (7MB) and 58,000 words (5MB).

It wasn’t resolved for me. I just switch to the different view each time. :frowning:

Thanks. I sent in one of my projects for L&L support to debug.
I can’t swear that the behaviour was different before, but something at the back of my mind started niggling telling me I’ve seen a different behaviour before. That, of course, may have been the Interactive Tutorial.
I tend to fiddle out of curiosity, so I may have corrupted the Manuscript folder sometime, if that’s possible.

I sent my WIP to L&L support and they got it right on their side to stop the mode defaulting to Corkboard view when clicking on Manuscript. They sent the “fixed” project back to me.
As life would have it, it still misbehaves on my side.
In a post to your original query, it was suggested that you invoke the lock icon in Scrivenings by right clicking for the context menu when hovered over the title bar icon just above the main editor. The last option on the menu is ‘Lock Group View Mode’. This worked for me with the project behaving, i.e. not popping to Corkboard view when clicking on Manuscript.
I did a cursory browse through the user manual to see if this would adversely affect my workflow in any way. It doesn’t.
On that basis, I’m happy to continue with this approach, as all I now have is an icon lock within the Scrivenings icon when clicking on Manuscript (and only on that folder). And if I need to move to Corkboard view at that level or Outline view, I simply click on those modes and the lock icon moves with my selection and works. It also does not adversely affect the various Layouts I’ve implemented.
Bottom line is the Lock Group View Mode works and I’ve found nothing wrong or irritating about using it as a reasonable workaround.
I say reasonable, because, trust me, I did my own debugging on my work in progress and the bug randomly kicks-in only after countless folders have been added to the project. You’ll find, if you create a new project, things will be fine until the misbehaving bug is suddenly there.
Strange, but true.

I had a look at your sample project too, and it is a very puzzling bug in how “sticky” it is for you, but how fragile it seemed to the both of us. For me, so much as moving stuff out of the Draft folder caused the problem to vanish. I was doing so to simplify the amount of data in that area of the .scrivx file, so I could better see if there were perhaps invalid codes or something attached to the Draft’s node in the XML. But by moving the majority of the files out by outdenting them, it suddenly started using Scrivenings mode!

That does bolster your theory that there is some kind of tripwire that reverts to Corkboard at a certain quantity of items. It is odd that it only seemed to trigger initially for us, and that once it was set to Scrivenings it stayed that way, so whatever this is, it might not be working properly.

It could also be legacy code from the v1 days. Back in the day if you loaded something in Scrivenings mode the software would lock you out until it finished assembling the session. This would mean accidentally loading a huge amount of data could mean having to go take a coffee break before you can resume working. The new model assembles in the background and lets you cancel by changing view modes or clicking anywhere else in the binder, so there really is no penalty to accidentally loading so much that it would take minutes to assemble a session. Thus if there is tripwire code, it is no longer relevant.

At any rate, I do believe we have enough to proceed with this, given the sample project does load in that state at least, and if there is a tripwire we can probably just remove it at this point.

3 Likes