want to disable all keyboard shortcuts

Hi

I just had a nasty experience where my fingers accidentally hit some keyboard combination that deleted a bunch of my text :imp:

That being said, I love this product.

I’d like to be able to disable ALL keyboard shortcuts as I don’t use any of them anyhow–I use the mouse and the menus. Can I do this?

On another note, I will have to figure out how to restore a file from last night…hopefully that will be easy.

thanks!

Kerry

Kerry, might you have pressed Shift-Del with an item selected? That would not delete anything, to be very clear, but it would move it to the Trash at the bottom of the Binder. There is in fact no way to delete anything in Scrivener with a single keystroke. You’d have to Shif-Del+Alt,P,E+ to have to accidentally move something to trash, activate the Empty Trash menu command from the keyboard, and then to confirm the deletion of the contents of the trash folder in the binder—a sequence even a cat jumping on the keyboard would most likely never trigger.

hi.

here’s what I think happened. My intention was to turn on the “italics” by hitting Ctrl-i but I fat fingered something and may have hit the “windows” key (lord knows what that will do) and what it DID do is take my file and create another one called file-1 BUT this file was missing all the text from AFTER the cursor and the original one only had all the text BEFORE the cursor.

thus I’d like to turn all that stuff off as I may fat finger it again.

here’s another thing that’s interesting: I couldn’t unzip my backups with 7zip or the windows OS due to however the rights are configured on the files. BUT I dragged the backup zip file to the desktop as the manual described–and this worked. too weird!! After that, I didn’t know how to run more than one project at a time (they have the same name hence backups) so I opened the backup and “exported” my files to the backup folder–I’m doing that from now on periodically. Then I opened up the current version of the project and renamed the bad files. Next I “imported” in the only file I needed, and all was okay. Gad, I was worried! I’ve only been using this program since about 4 months ago. The manual needs to place more emphasis on protecting and having the ability to restore the data in my opinion.

thanks, Kerry

You might have hit Ctrl-K, that’s what it sounds like, and that shortcut will split the current document in two at the cursor position just like you describe. It doesn’t delete anything, and if you do it by accident you can select the two files and use Documents/Merge to sew them back up together again. It doesn’t sound like you need to step back to a backup in this case.

You can customise shortcuts, in the Tools/Options... window. If you find one is getting in your way a lot, just disable it there. I don’t think an option to disable every single keyboard shortcut would be useful to many people. If we put in options for everyone’s individual preferences there would be no end to them.

There is a whole section on good practices for restoring from backups (such as the issue of how backups will be named similarly), and the various options available for fine-tuning things to work with the way you work. I’m not sure what else could be addressed here.

That aside, I have heard of the 7zip problem before. I am aware of a strange bug in our zip generator that can cause some programs to generate dummy files for each folder, and 7zip just outright chokes on it. They work fine with Explorer, which is the main concern, but we would like to get the issue fixed as it is a bit of a pain for those using Linux or Mac. The problem is the zip library we are using is what has the bug, from what I understand.

1 Like

@kboytzun thank you Kerry for this thread, and thanks to @AmberV for the menu location.

I use Google Docs quite a bit, and the command for external links there is Ctrl-K (as well for WordPress, and a few others). I do like to learn the different hotkeys for specific programs, but every now and then I go for Shift-Ctrl-L on Scrivener and my finger goes the K key by accident….

For anyone finding this thread 11+ years later, the Options menu is now under “File” (at least for Windows). And, if you want to keep the command in the list but delete the hotkey, select the list item, and on the right of the “Key Sequence” at the bottom there is an X to blank out just the hotkey.

I can see now how Murphy’s Law might now have me start wanting to use the “Split at Selection” command, but I’ll cross that bridge when I come to it. :sweat_smile:

Ellen