Way too much white space, why?

---- [SOLVED] ---- Found it.
Preferences/Appearance/Main Editor Default width = 0. Adjusted editor margins from 20 x 20 to 60 x 60. Much better now.

I just completed the upgrade to V3. it looks cleaner and I am looking forward to exploring more. The first thing I see is, what is all that white space doing in my document? I am attaching a screen shot to make the point.

I pasted in some text from this site for the screen shot example. The text should not be wrapping so tightly. The text should not be so very far away from the left border - or the right border for that matter. The text in the screen shot is Helvetica 18 point on a 100% page that is not in page view mode. There are no paragraph or line indents set for this text.

I don’t understand why at 100%, 18 pt font shows as 11 ore 12 pt font (relative size)?
I don’t understand what all the white space is and why my text is wrapped to a relatively narrow column sized width in the vertical center of the page?

Is there a preference setting I can adjust to fix this? I can use full screen and make that larger or crank up the view to 200% or more but that seems rather silly. I would like to understand how to eliminate or at least substantially adjust the rampant white space on my editor and document.


The additional white space is because you’ve got Fixed Width mode on for the editor — you could have had in Version 2, but you’d have had to choose it. In Version 3 the default is to have it on. You can turn it off with:

Preferences > Appearance > Main Editor – untick the ‘Used Fixed Width Editor’ option.

BTW: this and a lot of other changes are flagged up in the Tutorial (from the Help menu of course). It has a collection (‘What’s new in Scrivener 3’) which won’t take you long to go through but will give you a quick breakdown of what’s changed.

In particular, if you used V2 compilation much, you will save yourself a lot of time and possible frustration if you read the section on how compilation works now — it’s actually simpler and more powerful, but it is different, so it’s worth finding out how it’s supposed to work before getting stuck in…


Thanks. I had started the tutorials the other day and got side tracked. I will do my best to ask more educated questions if I can. :wink:

You asked a perfectly fair question!

It’s just that that section of the tutorial goes through the basic changes quickly and it’s a good overview – very helpful when you come to wondering why things in compile don’t work like they did in V2 (we’ve all been there :smiley:)

THANK YOU! This was driving me crazy, I kept looking for options within the formatting section.