What does this button do...?

Just out of curiosity. While trying out different option in Scrivener I cam across an icon that looks like a typewriter, but I can’t click it.

What does it do and how do I use it?


Typewriter mode? It’s available when the focus is in the editor.

I don’t understand it still. I searched for things like editor mode or Editor screen, but I can’t get this option activated.

The editor is just the place between the Binder ( the list of all of your folders & documents) and the Inspector (where it shows the Synopsis, Notes, and other metadata). The editors have 3 (actually 4, sort-of) modes: Cork board, Outliner, and what I’m going to call “text” mode (not the official name, I can’t recall what it is). The text mode of the editor is where you do all of your writing; it should just look like a white area where you can enter text, like in a regular word processor. If you click into the editor in that mode, you should be able to turn on typewriter mode.

Did you check the Help file for an explanation of what typewriter mode does? It keeps the text vertically centred in the screen as you type.

Yes, I checked it now, I understand what it’s for, but I still can’t activate it. The menu option is greyed out:
Screen Shot 2012-07-25 at 12.07.20 AM.png

As advised above, is the cursor in the Editor pane (i.e. the pane in which you do your writing)?

Yes, I checked it while writing in the editor, but no luck. I don’t know why it doesn’t work. It’s not that big a deal though, because I don’t need it. I was just curious what it did. Thanks for the suggestions.


Typewriter Scrolling isn’t available in page view. If you select View > Page View > Hide Page View, the option will be available. Purely academic, since you said you don’t need typewriter scrolling and presumably you do want page view. :slight_smile:

And now it works… Thanks! :smiley:
Actually, I do like this much more than the “normal” setting, and combine it with a nice type writer sound (I am using the NoisyTyper app) it’s good fun!

D’oh, it didn’t occur to me that you might be in page view, sorry about that!

No problem. One last question. Is it possible to use Typewriter in Compose mode? I checked settings but couldn’t not find anything on this.

great option though!


Yes, you just need to toggle it on while you’re in compose mode, using the keyboard shortcut (Ctrl-Cmd-T) or by mousing to the top of the screen and selecting the option from the menu. Each of the split editors and compose mode are toggled individually.