What Happened to My 'Indent' Functions?

I suddenly do not seem to be able to indent anything.

As you can see from this screenshot,

…the <ctrl+cmd+> arrow combos are all dimmed out - which seems consistent with the fact that none of them work.

Did I unknowingly change a setting somewhere? How do I fix this?


Where is the cursor when you did this screen shot? When I have the cursor in a paragraph in the editor, I don’t see an issue. I accept that you see an issue, so we’ll figure it out.

Can you display the Ruler and change the indents there?

In the “Tabs and Indents …” dialog box, does changing indents work there?

Under windows, when in a situation where those functions don’t apply, it is the whole menu that is grayed out (not just the corresponding shortcuts). I don’t know if it is the same for Mac, but if so, perhaps that is a hint.

You can also see in the screenshot that those ain’t the only shortcuts that are grayed out.

I’d be curious as if perhaps it is not all of your shortcuts that are like that. (?)

If the command was actually deactivated then the whole line would be grey. The shortcuts being grey is just Apple being weird about the cosmetics.

Now as for why they are not working as reported, despite being active, that will require a more detailed report, preferably starting from a test project created using the Blank starter, and each step documented—I don’t see any issues with these commands.

I think I just found a clue.

It appears I am typing inside a Table:
Screenshot 2022-12-04 at 8.07.57 AM

So, two questions:

  1. Is it possible to remove a Table from around existing text? Other than by cut/pasting the text outside the Table?

  2. How do I get the cursor OUT of the Table? Even when I place the cursor below the table, the table extends when I hit and new text appears within the Table.

The answers to those questions will likely resolve my dilemma.



Ah, tables are a wrinkle! They shouldn’t actually be blocking the keyboard shortcuts, but what happens when you use some of them inside of a table is decidedly different than outside of one. To understand that, it’s good to know that the Edit ▸ Move ▸ Left|Right commands share space with the main Increase|Decrease Indent commands. Outside of a table they are synonymous, but inside of a table they take on an alternate use for moving columns (Up and Down, as you might expect, moves rows).

That said, you should still be able to manually invoke the indent menu commands and have them work as expected, within a table cell, or even cells if you have text from several selected, so that wouldn’t fully explain why they aren’t working at all.

Is it possible to remove a Table from around existing text? Other than by cut/pasting the text outside the Table?

Right-click anywhere within the table, and you’ll find a “Remove Table” command from within the Table submenu.

How do I get the cursor OUT of the Table? Even when I place the cursor below the table, the table extends when I hit and new text appears within the Table.

Yeah, the text engine is a bit messy when it comes to tables that start or end a document. I would recommend always inserting them between lines rather than at the very end or beginning of a chunk of text.

Of course now you know how to remove the table and linearise the content—but in a case where you do actually want a table, the best workaround I’ve found is to add a new binder item after the one with the table, select both and use Documents ▸ Merge. That’ll add a line below the table, or maybe even two depending on your merge separator settings.

Thanks for these tips. I hope I can remember them the next time I find myself in such a predicament.


Well, I’m glad we got that figured out but now I have a new problem.

When I try to indent a paragraph, it gets deleted.

This first screen shot shows a snippet of text. I want to indent the line that starts with “What’s” (btw, once upon a time I could indent before I entered a character, now I have to have a character first. But I digress):
Screenshot 2022-12-06 at 7.49.48 AM

So I hit enter the ‘indent’ keys, and this happens:

Screenshot 2022-12-06 at 7.50.04 AM

… and another morning is lost to troubleshooting instead of doing anything resembling actual work.

Anybody got a clue?

That is not an “indent” key. It looks more like a TAB.
If you had your text selected when you typed it, in this case yes, the text will be replaced by the TAB. (Though invisible, it is a character. Occupying “physical” space.)

If you did indeed use the TAB key, note that this isn’t quite the best way to do it.
You should do as in your original post.

Now that the table question is out of the way, it should work.

“Should” being the operative term there.

I was not using the ‘tab’ key… I was using the ctrl+cmd+right arrow combo.

Just now I took your suggestion, and went to the Format > Paragraph > Increase indent menu - and got the same result.

Also, the text was not ‘selected’ - I just had the cursor on one side or the other. That’s usually enough to get the indent.

I use indents a lot, now I can’t use them at all.

And so it goes.



Oh well…
I am under Windows, so it might be different, but for me an indent has no character to show (invisible or not). There is an indent, but other than that nothing to see.
Meaning you can only tell there is an indent because of the indent itself. Without any text, ruler aside, you couldn’t tell.

If you’re tired of trying to work this out, why not do a zoom session with me and get it straight in half an hour?