What is colour of iOS inline annotations?

Well, the title says it.…

What is the colour, the actual RGB hexadecimal code, of iOS inline annotations? I cant search for them on the Mac, not even if I use the eye dropper tool to pick up the colour to search for. I’d really like to make inline annotations on iOS (where I don’t seem to be able to choose a colour) and modify them later on the Mac to the colour I would prefer, but can’t search for that pesky iOS colour.

Thanks in advance for all help!

Hmm, that’s a good question! When I create a sample project on iOS, add an annotation and then send the project as a .zip to the Mac, if I open up the internal RTF file and look at the annotation code, I see it is using #AF1C00 for the colour (RGB 175/28/0). However if I then type that in manually into the Formatting Finder tool and attempt to search for annotations of that colour, I get no matches.

Of course, by that point the RTF file will have been converted to macOS format, which doesn’t use hex code but floating point RGB, and evidently in conversion the actual value drifts. If I create another annotation and specifically set it to #AF1C00 on the Mac, then search, the annotation is found, but it is noticeably darker than the one that came from iOS, and the internal RGB designations in the RTF file are different:

Converted iOS annotation:

\f1\fs24 \{\\Scrv_annot \\color=\{\\R=0.686275\\G=0.109804\\B=0.0\} \\text= \f0\fs26 annotation from iOS \f1\fs24 \\end_Scrv_annot\}

Native macOS annotation:

\f1\fs24 \{\\Scrv_annot \\color=\{\\R=0.61613\\G=0.044307\\B=0.011843\} \\text= \f0\fs26 annotation from macOS using #AF1C00 \f1\fs24 \\end_Scrv_annot\}

The eye dropper tool on text is unreliable in my experience. Here is a simple test result using TextEdit:

  1. Paste in the “Black Large Square” Unicode character several times.
  2. Select the first square and give it a colour.
  3. Select the following square and use the colour picker to select the colour of the square to the direct left.
  4. Select the next square and repeat, using the square to the left.


We’re using the colour picker to set each square from one original source, but as you can see, even with this short sample there is visible drift. It’s a level of drift that seems to go beyond rounding errors in how dramatic it is. It is at least consistent in that if I always use the left-most square to colour each subsequent square instead of the previous square, I get the same wrong colour over and over.

So there is that… I guess.

Pooh. Thanks for your efforts, but it doesn’t seem like I’m going to be able to achieve what I’d like. Your experiments with the eyedropper tool in particular demonstrate why my experience with setting annotation colours on the Mac has been so disappointing.

Floating point colours. How messy. I blame you, Apple.

It used to be better! I don’t know exactly when it got this way, but I know I used to be able to pull out colours from text and search for them.

Actually, I just tried using hex colour AF1C00, by manually adding the colour to a custom palette and then selecting it, and it worked to find iOS annotations! For all that the displayed colour is much darker, as you say, I’m not arguing with success here.

Huh, glad to hear that’s working for you! I had tried that as well, I still even have the colour saved into the palette hot bar from the last time, but it doesn’t work for me.

UPDATE: sometimes searching for a particular colour works, and sometimes it doesn’t. Success or failure doesn’t depend on whether the annotation was made in iOS Scriv or in Mac Scriv, whether the colour was pulled from the same palette or a different palette (with the exact same colour). It’s to all appearances random, and I don’t feel like spending the time to do a statistical study. :smiley: I got lucky with the search for the iOS colour above. I’ve gone back to not depending on this feature.