When Importing Scapple Files into Scrivener Project, Link to the original Scapple File than Creating a Duplicate File

When dragging Scapple files into Scrivener, I notice that they are imported as duplicate files. Furthermore, there is no option to add it as “Existing Files” (when you right click > Add > Add Existing Files). Also, for the Add Existing Files, is there are particular reason why Scapple documents are not supported e.g., is there a deficiency in supporting non-text based documents? By importing it as a duplicate file than linking it to the original file, not only is it embedded in the project and stuck in the project, but it also can’t be opened externally without launching the project. Also, I am not sure if it can be located in the Scrivener project folder (allowing us to move a folder of Scapple documents into the Scrivener project folder e.g., the Files folder would also be helpful).

I think something else that would be nice is to allow an external link to a Scapple project file (like a hyperlink) where I could click and it would open the Scapple file externally. I know that you can do this with Scrivener documents e.g., create an external document link and paste it in another project and think it would be useful to have this feature for Scapple files as well.

File ▸ Import ▸ Import ▸ Research Files as Shortcuts (as Aliases on macOS) is the command you’re after; that will list the item in the binder, but with a link to its external location rather than having it copied into the project folder.

Only text files can be imported into the Draft folder in the binder, so it sounds like you may have had that or one of its subitems selected when you tried this. If you click elsewhere into the binder, e.g. on the Research folder, you should see your other file types available for importing. Note though that this command will copy the selected item into the project rather than linking to the external file—it’s just another way of accessing File ▸ Import ▸ Files...

This is part of the file system, not Scapple or Scrivener specifically. Depending where you’re putting the link, you may be able to just drag the file from File Explorer into the text editor to create the link (this will work in Scrivener), or Ctrl+Shift+RightClick the file and select Copy as Path, then paste that and add file:\\\ as a prefix to the path to create the link (remove the quotes from the pasted link). In Scrivener, you can paste the path (or even drag the file) into the Edit ▸ Add Link... dialogue and select the file prefix to create a link on selected text.

1 Like

Thank you for your help.

I am on Scrivener for Windows and when using Import ▸ Research Files as Shortcut, the shortcut will always have the issue of Missing Shortcut Target: "" This might be a bug as I tried it for various files and file types.

Adding the file:\\\ prefix to the path did not seem to work (could you provide an example? I tried file:// and file:/// file:\\ etc) as it would not convert to a link though Edit ▸ Add Link... did work (which is the perfect solution). Do you also happen to know the difference between Adding a Link as No prefix and as a File? For context, the options are to add a link as a Web, File, Email, and no prefix. I do notice that no prefix would not launch the file as it does not have the file:// extension (but when would you use it?).

Thanks for your help!

It’s not a common problem; I’m able to import a Scapple file as a shortcut just fine, so it sounds like there’s something else at play. Is this an error that shows up when you attempt the import or sometime later when you’ve reopened the project? Are the project and the Scapple file you want to link both stored locally on the harddrive?

Sorry, this was just an example of what the link looks like; to actually make it into a hyperlink would depend where you were using it. Scrivener does not, unfortunately, currently automatically convert it to a link (though like I said, you can just drag and drop the file into the editor to create a link, too). In MS Word, you can type/paste a path like file:\\\C:\Users\MimeticMouton\Documents\ScappleTest.scap (or file:///C:/Users/MimeticMouton/Documents/ScappleTest.scap) and it will be recognized as a link.

Do you also happen to know the difference between Adding a Link as No prefix and as a File ?

It’s a pretty simple tool; the File prefix literally is just adding file:// in front of whatever you paste into the text field, Web adds http://, and Email adds mailto:. Depending what you’re entering in the field, Scrivener will automatically set the prefix, e.g. if you drag and drop from File Explorer into the dialogue, Scrivener will set the file prefix to fit with the way it converts the path (e.g. it will put /C:/Users... in the text field, which is why there’s only two slashes in the prefix), but you could also leave it as No Prefix and type the prefix yourself.

1 Like

When I import the files as a shortcut, it will have no link to click to the target. The file title will be faded gray and have no underline (rather than with blue text and a blue underline) and at the bottom of the editor where the word count/document type is, it will say the Missing Shortcut Target. I did manage to get the Research Files as Shortcut feature to work in other Scrivener projects, but it seems that this issue is just for the Scrivener project I am currently working on. Do you know what project settings might be responsible for this? My project is very large, but I don’t think it affects this feature. Or perhaps, it might be because the project was upgraded from Scrivener 1 to 3 and not a Scrivener 3 project from the start.

For the no prefix option, do you happen to know where I could find information on the list of common file prefixes I could use?

Sorry for the delayed response! That’s a really odd condition, seeing it only in a given project; I can’t think of anything intentional that would determine that on a per-project basis. (Really I can’t even think of any option that would affect how files import as shortcuts on a global basis.) Did you say whether the project and file are stored locally or in a cloud sync service like a Dropbox folder or Google Drive? Offhand I wouldn’t expect that to matter so long as the files were all really present on the hard drive (not just accessed temporarily from a remote server), but it’s a condition worth checking since it’s often involved in file access issues. Were you able to successfully import the same Scapple project as a shortcut to a different Scrivener project? (Not just use the feature in general, but use it with the same file that isn’t working in your main project.)

Something different to try, at least as a workaround, is creating a shortcut to the file outside of Scrivener, using the regular Windows tools, and then importing that shortcut as a regular file. It will look a little different but ends up with the same result of not copying the original file but appearing as a shortcut that will link you to the original, external Scapple file. You can delete the external shortcut after you’ve imported it.

Regarding the prefixes, no, I’m not sure of any general sort of thing other than the file protocol already mentioned. If you have a particular file type that you’re trying to open a certain way, I’d search online for any specific help or ask support for the program. Scrivener for instance does have its own x-scriv protocol that gives you the ability not just to link to a certain project but to link to a specific document within the project (so the project opens with that file loaded in the editor). That’s what you’ll get when you use Copy ▸ Copy Special ▸ Copy Document as External Link.

1 Like

Yes, the project with the issue is in a cloud service folder (also saved locally) as was the other project which allowed the shortcut. The shortcut targets were all on the local drive.

Something different to try, at least as a workaround, is creating a shortcut to the file outside of Scrivener, using the regular Windows tools, and then importing that shortcut as a regular file.

I did try this - but it seemed that shortcuts to any file including shortcuts did not work and the shortcut link was deleted so the project target was empty. I believe that the file protocol for Scapple works when I paste it into the text editor - I just wouldn’t be able to drag the shortcut into the binder (which is just a minor inconvenience). No worries though! Thanks for your help!