Where is my disk space?

Dear Techie Types,

My MacBook laptop has a ~120GB hard drive.

When I choose ‘Get Info’ on ‘Macintosh HD’, it tells me that the capacity of the drive is 111GB, with 95GB used and 16GB available.

When I choose ‘Get Info’ on each item inside the ‘Macintosh HD’, I get the following:
Users - 25 GB
Applications - 9.49GB
Library - 7.99GB
System - 4.56GB
Developer 2.44GB

They are the only items inside Macintosh HD, and their total size adds up to about 48GB.

Separately, I ran an application called DaisyDisk which gives you a graphical view of where all the data is on your disk (I find it useful to clean up disk space when I am running low). Daisy Disk reported that the total data on ‘Macintosh HD’ was around 46GB.

Which leads me to ask - where is my missing 50GB of disk space?
Are there 50GB of hidden files that I don’t know about?
Using ‘Disk Utility’ I tried ‘Verify Disk’ and it reported no faults, but is my disk stuffed anyway?


An update:

Following the advice on this website: forums.bombich.com/viewtopic.php?t=3852

I have found that my /Volumes folder has two items inside.
One is an alias called ‘Macintosh HD’ and points to ‘/’.
The other is called ‘Macintosh HD-1’ and points to ‘/Volumes/Macintosh HD-1’.

This ‘Macintosh HD-1’ folder contains what appears to be an old copy of the entire Hard Drive, and is about 46GB in size - more or less the amount I am missing.

Is it safe to delete this? And if so, what is the best way to do it?
I cannot drag it to trash directly, as it says I do not have sufficient privileges for some of the items.


Some type of backup software running?

From the terminal what do you get if you do:

  1. mount
  2. df -k

most likely there are other accounts on your computer which have some stuff in the trash. Log in as the other users and empty their trash and see how much you recover.
The same applies to external drives, each volume has their own trash which under normal circumstances only the user with the correct UserID can access and see but the free space is missing for all users, of course.
Hope this helps

Only one user account left. There were other accounts, but they were deleted a while back (actually because I thought I needed to save disk space because it was already getting low). There aren’t any visible backups of the old user accounts either - so if something is left over, not sure how to get at it.

Jaysen - I am heading home now to test out your instructions and will post the results.

If there is no easy solution, there is no real problem with me doing a re-install of Leopard, as I have all my files/emails/applications backed up on another computer anyway and can easily copy them across.


Filesystem 1024-blocks Used Available Capacity Mounted on
/dev/disk0s2 116884912 99138560 17490352 86% /
devfs 104 104 0 100% /dev
fdesc 1 1 0 100% /dev
map -hosts 0 0 0 100% /net
map auto_home 0 0 0 100% /home

The odd part is that the files are in “/Volumes”. This is normally reserved for mounted disks.

You can try the following to see “what breaks”. In terminal:

cd /Volumes
sudo tar czf "Macintosh HD-1.tgz" "Macintosh HD-1"

My guess is that you will get a “disk full error”. If you do not get an error you have successfully backed up the data and now want to remove the extra data:

sudo rm -rf "Macintosh HD-1"

Let me know how it goes.

Hi Jaysen,
I actually ran that exact remove command the other day after I posted the first message, and it came up with a message saying that I did not have permission to delete the files.

Looking in Volumes now, I see that ‘Macintosh HD-1’ has disappeared after a restart from trying to execute that command.

Unfortunately, the hard drive space is still unavailable and I have no idea where it might be now.

This is a long-shot, but execute this command from your home-folder:

sudo du -x / | sort -rn > sizes.txt

Then just let that run in the background (should take about 5–10 minutes). If you get any error messages while this runs, might be a good idea to save those too. It will generate a report called “sizes.txt” listing nearly every single directory on your computer and sort them by size, showing the size in blocks. Keep in mind the resulting text file will be fairly large (mine was 18mb and nearly 200,000 lines in length): so choose an appropriate application to open it in.

Unlike the other tool you were using for this, du will go into areas not generally shown in the Finder. If there is a lurking phantom trash folder or something, this should root it out.

P.S. I don’t think whatever was in Volumes was actually taking up the space. That was disconcertingly weird, but nothing should be there except mounted volumes, and mounted volumes don’t consume space on the host drive. What is troubling is that the mount appeared to be itself. That shouldn’t happen.


My thought was that a backup tool had created a loop device and placed it in Volumes. Hence the request for mount. My other thought at this point is some app is not properly unlinking allocated block from files. Think back to the early MYSQL days when the table space shrinking tool never actually returned blocks to the FS. I think that bug lasted all of 2 minutes.


If you change Ioa’s line to

sudo du -x / 2>&sizes.err.txt | sort -rn > sizes.txt

errors will be captured in the sizes.err.txt file. That will make it easier to scan them later.