Whoa! Hold it!

Forgive me for dashing this off without finding if it has already been reported before, but I have found a definite problem with the new 025 install.

Control-Delete will deposit whatever text file I’m working on in the Trash.

Using ctrl-delete on a word will sometimes trash the entire file instead of the word. This happened on both my XP and W7 machine. The bad thing is that this trashing doesn’t happen every time, so I’ll keep working with it to see if I can pin down the particulars.

A further note (since no one else has commented, yet)-- ‘highlighting+delete’ works fine for deleting blocks of text, as does ‘highlighting+ctrl+X’.
Sorry for the panicky :open_mouth: title. I should have done my deep-breathing first.

Ctrl-Del will trash the item if it’s selected in the binder, corkboard, or outliner, the way that Delete alone used to do. If you’re working in the text editor, then it should not trash the item, so the problem may be that you’re moving the focus before hitting the keys–that’s what I’d check first, anyway. If you’re getting it otherwise, do report back.

Yes, I did, indeed, select the text editor when it happened. (Specifically, I typed in a word, moved the cursor to the start of the word and then hit ctrl-delete, which resulted in the movement of the text file to the bottom of the trash bin.)

XXXXXHowever, not only was the text file moved to the trash bin, the focus went back to XXXXXthe binder.

Strike that. After further checking and delying myself, I find that the file moves, but the cursor still blinks in the text editor and the word is not deleted.

Still puzzling with it.

Okay, I see it. Ctrl-Delete will send the document to the trash, even with the focus in the editor, whereas the in-progress shortcut PDF Lee posted says that Ctrl-Delete in the text editor should delete a word to the right. Ouch.

This is (or should be) separate from Ctrl-Backspace, which will delete a word to the left; that one should still be safe to use.

Well, it happens with both the XP and the W7 laptop. The control key and the delete key are stand-alone, with no remapping.

The ctrl-backspace key works as advertised.

The XP is stock Dell 4550 with the standard keyboard, while the Toshiba laptop keyboard appears to be standard. I’m trying to figure what software they have in common that might have contributed or remapped their keyboards but so far, nothing stands out.

If you find something, that’s great, but don’t worry too much about it. I’m just curious because you’re getting it inconsistently doing one thing or the other, but definitely this is still a bug since Ctrl-Delete shouldn’t delete the document while you’re editing it. Thanks for catching that.

Thanks. The reason I panicked when I first saw it is that it is one of those ‘automatic’ key-strokes for me–I use it quite often without thinking, and it is only a quirk that let me catch it before I emptied the trash. I can live with it, but I’ll have to be extra alert.

As to why it happens to me and (apparently) no one else is a mystery. :slight_smile:

Understandable panic! I’m glad you caught it in time, and I’ve made an announcement post that addresses this and a few other shortcut conflicts so hopefully you’ll have saved a few others from this problem, too. Thank you!

I hate to say it, but the problem is back again with Beta 035.

Now, Shift-Del will trash the file I’m working on. I understand that shift-del should trash a file selected in the binder, but it should not do so while I’m working in the editor. Why? Because I use shift-del to cut and paste a word/phrase about in the file. It’s an old habit, I’m comfortable with it, and for the longest time it worked that way in earlier betas. Now, suddenly, I’m having to learn a new way to do things.

By the way, how DO you move things around in the text file if you can’t cut and paste? Ctrl-del doesn’t work any more, either.

Also, when shift-del pops the file into the trash bin and I have to mouse it back into the binder, it’s tedious to try to figure out exactly where it’s going to wind up (as a peer or as a child). Whatever the goal was for the new style of place-marking, it’s not working for me. If you keep that feature, please make it optional. I enjoy Scrivener because it makes things simpler, not more complicated.

Sorry if I grouse. Scrivener is a great accomplishment and I’m looking forward to using it for all my work. Though I do wish I didn’t have to keep relearning all the time. Lazy, that’s me.

Sorry, Lee’s working on disabling this when the focus is in a text area; it should only work when the focus is in the binder, outliner, corkboard, etc.–somewhere that’s an outline list of items, rather than inside an item itself. In the meanwhile, you can go into Tools>Options and under the Keyboard tab, filter by “Remove” to bring up the “Move to Trash” command and just change the keyboard shortcut there to something you’re not going to accidentally hit while in the editor.

Ctrl-X functions the same as Shift-Delete to cut text and Ctrl-V pastes.

The binder drag and drop is experimental, as Lee said; we wanted to get some feedback on it (so thank you!) and we’ve been discussing necessary changes internally as well, so this isn’t the final-release version