Why do I get an empty line after hitting return?

Every time I hit return, I get an empty line instead of only going to the next line. Why is this?

Presumably you have paragraph spacing set up to leave a gap. Check out Format > Text > Line and Paragraph Spacing…

1 Like

I cannot find it in Preferences, so I think you mean the setting in the menu, right? The option is greyed out, but when I select all the text I can open Line and Paragraph Spacing, I attached a screenshot of what I see.
Screen Shot 2014-05-07 at 15.32.26.png

Yes, the “Format” menu. To see the line settings for where you hit return, though, selecting all the text won’t help - you need to place the cursor at the place where you hit return.
All the best,
Keith

1 Like

Still doesn’t help. There must be another way to fix this. I also saw that I am not the only one with this problem. There are a lot of posts that talk about empty lines after a paragraph command. Maybe I should copy and past the document in a new template or something like that? Or can I strip that setting out of the document?

It has to be part of your formatting - there’s no way Scrivener can just randomly insert blank lines. You’re not in scriptwriting mode are you? (Check the footer bar - can you see your word count?)

Also, please double-check: is there an actual empty line there that can be deleted, or is it just spacing? That is, can you click your cursor into the empty line and remove it? If not, then it is paragraph spacing.

1 Like

Another thing to try: put the cursor inside any of the paragraphs that have the extra whitespace, and reformat using one of the premade paragraph formats - you will find these in the button on the toolbar directly above the editor area where your text is, just to the left of the font box selector, marked with a ¶a

Do this for a paragraph with the whitespace above it and one with the whitespace below it, since you don’t yet know whether the extra leading is going in above or below the paragraphs.

You can also try formatting a dummy paragraph with the settings you want, and adding that to this premade toolbar dropdown. Then it is simply a matter of putting your cursor in any paragraph with the added whitespace, and reformatting it to YourParagraphStyle via the toolbar.

  • asotir

I still was not able to fix the problem. I cannot place a cursor in the empty space, so it must be paragraph spacing, but how do I tell Scrivener not to create this after hitting return?

One thing that can help a lot with stuff like this is the Format - Options - Show Invisibles menu choice. This will show a pilcrow ¶ at the end of every true paragraph. Whitespace that is a true empty paragraph will just show this small ¶ at the left margin.

As to how to eliminate this extra spacing, remember that Scrivener, outside of Script Mode that is, will simply recreate the paragraph formatting for the previous paragraph every time you hit Return. So to eliminate this on the current and next paragraph, follow the previous instructions for formatting the current paragraph: place the cursor inside the paragraph, and fiddle with the spacing options (look in the formatting toolbar for the button that is marked, “1.0”) - you want ‘other’ in that menu, which will bring up all your choices there). Whatever you choose as your options will be duplicated on the next paragraph as soon as you hit Return at the end of this reformatted paragraph.

If you would like to do this all at once for a document, look at the Documents menu, under Convert, the Convert Formatting to Default Text style, which brings up a little warning and some more info before you press the do it button.

There are many suggestions for how you can proceed in this thread, but you still seem to be a bit at sea about it all. One thing you might think about, then, is to ignore the extra whitespace, and when you are done editing and ready to submit the work, compile to a format readable in your favorite Word Processor. You can then adjust paragraph settings and whitespace in that program.

  • asotir

A post was split to a new topic: Unwanted empty lines