Why does double-clicking on embedded images not always work?

I have a bunch of images embedded in some of my documents. Usually, I can double-click one and get the little pop-up that allows me to change its size. But for some images it just doesn’t work - I double click on it and nothing happens. What am I doing wrong?

If they are PDF format images, they cannot be dynamically scaled, that is just a limitation of using them—make sure to size them correctly before dropping them into a text editor.

hmmm. I’ve got at least one that I know was a JPG that’s doing this…

There wouldn’t be a normal reason for that then. It could be the editor is just jammed up, have you tried restarting the software? Are there any settings other than vanilla in the editor, such as Page View, or Scrivenings mode?

nope, those seem to be off, and I’ve tried restarting it several times. What I can do is select the image using the cursor (position before the image, hold shift, walk forward), cut, paste into Photoshop, select all, and paste back into Scrivener, and then it works and I can resize it. A pain to do it to all my images though… And, weirdly, it doesn’t always take. Last night I resized a bunch of images and saved. This morning I open Scrivener and many are back to their original size. I resized them again, saved, quit, opened, and now they are the correct size. So it’s not just that it doesn’t stick across save/open operations, but definitely something happened where the new size didn’t keep, at least last night.