Why is it always stuck in typing?

Hi there. I’m a Scrivener Mac user from China (pretty rare I suppose since this baby doesn’t support Chinese language).

Since I updated my software to version 2.8, I always confront with the problem of typing stuck. I wonder if anyone else have the same problem. I’m writing my English dissertation with English input method. Sometimes when I try to type the words, the marker just stuck on the screen no matter how many words I have typed, and when I move it a little bit suddenly all of the words would come out together.

I wish someone can give me a helping hand on this problem.

Thank you!

If by “doesn’t support Chinese” you mean there is no Chinese interface version, you are right; if you mean you can’t type Chinese, you are totally wrong. I have been using Scrivener handling Chinese since late 2006 before the launch of version 1.0 and the only problem I have had with Chinese text was for a few months when collaborating with a Chinese colleague using the Windows version of Scrivener when it first came out, and there seemed to be an encoding problem for Chinese characters between the two operating systems. That resolved itself within a couple of months.

As for your cursor getting stuck for a few moments, that sounds as if there is something slowing down the automatic back-up saving, which is set by default to trigger after 2 seconds of inactivity, or it could be something else on your system hogging processor cycles at those points. Without knowing more about your hardware, which version of OS-X you’re running, and what else you have running in the background, it will be hard for any of us users or anyone on the team to give you much advice.

I currently use Scrivener v. 2.8, mostly on a late 2010 MacBook Air, with 2GB RAM, a 1.8 GHz processor, running OS-X 10.11.6. I have never had any such problem at any point in my use of Scrivener over the last 10 years, so it must be something to do with your specific set-up.



I have been having this a lot in the past day as well. I have a scrivener project with maybe 30,000 words of text. Whenever it tries to auto-save, I get the spinning beachball and activity monitor says that it is taking up 100% of processing power. It thinks for maybe 20 or 25 seconds and then I get to keep typing or using scrivener although of course then it starts up again within a few seconds.

I’m on a Macbook Pro (OS 10.11.6) and using the latest version of scrivener.

Do you have a lot of other apps running?
How is your project structured? Lots of small pieces or a few fairly large pieces?
What time limit have you set for the auto-save feature?

I think I have some problem in typing Chinese as well.

When I use scriptwriting templates to write Chinese screenplay, I cannot input Chinese character as I want. Every single time I tried, some English Letter will come out. For example, When I input D-A-I in Chinese input method to get a Chinese character 带,there will be a English letter D come out first and followed by the Chinese character 带. But I don’t need this D at all, all right?

And if I type too much Chinese character very fast, the software just crashed.

All other templates are good to use except scriptwriting templates.

Really hope someone could help with this problem.

I’ve never tried scriptwriting, let alone in Chinese, and I’ve never had any such problem with typing Chinese … mind you, I’m very slow.

Can I ask: what Mac are you using and how old, e.g. 13" MacBook Air, late 2010; what version of MacOS, e.g. 10.11.6; and what Chinese entry system are you using, e.g. MacOS Pinyin Simplified? It would help to know.


Just had a quick try on my system as above. I had to modify the Script Settings to use Chinese—PingFangSc font—and to remove the capitalisation for all script elements as uppercase is treated as Roman, rather than Chinese. As I say, I’m not the world’s fastest typist, even in English, but I didn’t have any problem of intrusive Roman characters and only wrote half a screenful while testing.

So let me know about your computer system and your input method, so I can try to help further.